Focus Fanatics Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Okay, so the other day I took the battery out of my 2002 ZX5 to use in another car. It had an electrical issue. So I got the other car to the shop and removed the battery and put it back in the Focus. It would not start, the infamous rapid click would occur. So I figured it got drained by the other car's issues. I took it in and it tested bad. Got a new battery. Got home and had the same problem. Click Click Click. The gauges fly around, the lights work, just no starter movement. One odd thing that makes me nervous is that the radio keeps coming on every time I try the ignition, even if I turn it off. I figured since the only thing that changed was the battery, it might be the terminal connections. I cleaned them and tightened them. Still no luck. It seems like the clicking is coming from near the starter, but it is tough to tell. Then the thing starts up randomly. Nothing different was done, it just starts. I let it run for a while, and then turn it off. Tried to start it and got the clicking again. I gave up for a while and the next day I tried it and got nothing. No click, no lights, zip. The A/C light does come on for a few seconds and there is this strange hum, but nothing else lights up.
I am concerned that it is some Computer issue. Anyone have an issue like this or have any suggestions? Also, how can I hit my starter with a hammer? The thing is barricaded in there with seemingly no easy access.
 
1 - 1 of 1 Posts
Top