Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #1
ok well my cruise control hasn't been working and when I brought it in to the dealer to see what was going on they told me that there was a problem with the aftermarket Tb and that it wasn't the right one... [rolleyes] .

Anyways I didn't think anything of it so a few days go by and while I was at the gas station I decide to pop the hood and to my surprise I find that the cruise cable is completely dis-connected. So I continue to drive home and look at the work order papers that I you get when you pick up the car and it says that there was a porblem with the cables and they ordered a whole new set. So I go look at them and they do look pretty new.

Anyways I didn't care that it was dis-connected so I tried to re-connect it and the problem is that when I connect the cable the black piece that hits the adjustment screw to stop the plate does not even come close to hitting it so why is the cruise cable so short???

I had them all connected when I installed the TB so what is going on with this thing??? Should I just take it off and trash it like I was going to do a while back???

Any help would be great... thanks guys[thumb]
 

·
all grown up
Joined
·
3,949 Posts
sharon right??? Anyways there has to be some way to exchange it for a new one. I am gonna buy one soon but I haven't yet so I can't help you with the technical stuff...but it sounds to me like either the ST doesn't support the throttle body or YOU GOT A LEMON TB...Anyways good luck with it i'll be watchin to see what happens.
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #3
yeah thanks... BUT... I don't think it's the TB because besides the weird RPM thing when stopping it worked fine... I think something happened at the dealer that they aren't telling me about because everything worked fine before I brought it in... Sorry if I am coming across as an ass but I still trying to understand why this thing is giving me so many probs.
 

·
Registered
Joined
·
3,022 Posts
you know that the cossie throttle body only works with the cosworth intake manifold... right?
 

·
Registered
Joined
·
528 Posts
lol, and the cossie intake manifold you have to re-locate your power steering...
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #6
no I have the 05 style engine bay... [:D]
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #7
wickedgreyzx3 said:
you know that the cossie throttle body only works with the cosworth intake manifold... right?
and why do you say that???

I have talked to Randy and Ivan at focussport and they said it will work just fine with the stock intake manifold. I also talked with someone (don't remember his name) at Cosworth and they said it would work just fine... although the guy I was talking to at Cosworth said I may need to a tune but he's not too sure... but thats ok I should be getting my tune very soon.
 
1 - 7 of 7 Posts
Top