Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hey folks, first post, yay for me. Anyways, reason for the post. I did an oil change on my girlfriends SVTF yesterday and when removing the oil filter, discovered the oil filter in there was not the one listed in the manual. They used the FL-2005, which is listed for the other engine, as opposed to the FL-400. Do you think this caused any problems, or is it an acceptable mistake? Thanks for the input!
 

·
Registered
Joined
·
132 Posts
HRM... I use the K&N 2009 filter for my oil filter! Wouldn't waste my time with motorcraft one....


The K&N is a much better filter and runs around $10.00..

Hope this helps...


Also RUN MOBILE 1 or AMSOIL FULL SYNTHETICS!

Just my reccomendation!

Oh yeah! Please tell me you put 5w30 in the SVTF and not the "OWNERS MANUAL" 5w20!!! Because there is a supplament for the SVTF which states you must run 5w30, the SVTF required oil!

Some people don't read everything before doing things! HRMMM... Sometimes it is better to follow directions!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Ok, good to see there would be no problems because of it. First thing I did was flip through the primary manual, but then noticed the SVT supplemental.

I did however use 5w-30... same as my truck. Got the 5quart jug of Mobil 1 @ Walmart for like 17 bucks. Couldn't pass it up.

ps. Jonny, I see you are in Hampton. I am assuming you got yours at Portsmouth Ford. They are the ones who did the first change.
 
1 - 4 of 4 Posts
Top