Focus Fanatics Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hello, I have a 01 ZX3 with 199.000 miles I got for free due to the P.O. could not get it running well enough to pass CA smog. I did..
Done quite a bit to this car for use as a commuter. (32 mpg)

The other day, I added some Lucas Fuel additive before I filled up. As I took the bottle out of the filler neck, I realized I had just dumped the whole bottle in. Filled up and drove to and from work 60miles RT. Couple of days after, I drove it to the local store. When I started up again, it sputtered and died. 15A fuse blown, replaced and got it home. Did it one more time the next day. Replaced, ran ok. I'm thinking fuel pump at this time, but the Lucas thing is still on my mind. Went and filled the tank drove to work. Fuse hasn't blown, but now the worst mpg its ever had and seems to lack a little power.
Everything I've replaced has been Ford OEM. thinking the fuel pump as well.

any feedback would be appreciated.
Thanks in advance
 

·
Registered
Joined
·
18,198 Posts
You don't mention the most important thing, or how much fuel was in tank when you tipped the Lucas all in. Likely though, the Lucas had nothing to do with it and you are simply failing a very old part. If the additive would have been a problem you wouldn't have gotten through the 60 mile RT.
 

·
Registered
Joined
·
18,198 Posts
The thing to do when doing something like that is to immediately fill tank up to dilute the product back down, of course, too late for that now.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
Well, decided to run this tank out and see if the fuse pops again. (thank god for towing). Pump is working when key is turned on, 40psi while driving. I'm assuming 40 psi is the norm...?
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
Well it hasn't popped the fuel pump fuse again. Ran two tanks through it at this point. Now notice crap mpg. Was averaging 27-30mpg. well below that now. Seems like I have to put my foot into it a little more and a slight surge at hwy speeds since all of this has happened. Wth my reader in while driving, I'm getting 38-40 psi fuel press @ hwy speed.
Have to dig into it a little more.
 
1 - 7 of 7 Posts
Top