Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
842 Posts
Discussion Starter #1
I already bought and installed a AEM cold air intake and had to take it out due to it giving me problems with my engine light. I wanna know what Short ram intake's are out for the svt that are good. Does Volant make that one for the SVT? I dont want a AEM short ram either.
 

·
Registered
Joined
·
132 Posts
The "Short RAM" Is basically the same as teh cold air accept your pulling hot engine air instead of "COLD AIR" from the cold air intake.

If you were seriously having problems with the cold air you'll probably have the same problems with the Short RAM.

Also just a warning I recieved from my dealer... If you have these style of air filters (the ones that us oiled filters) they will void warrenty on things if they go wrong IE: Mass air sensor! I took all my mods off and will mod the car once the warrenty is gone... As why pay for stuff that should be free!? My 2 cents!
 

·
Registered
Joined
·
842 Posts
Discussion Starter #3
is there a aftermarket Mass air sensor that i could get that would keep my car from giving me errors so that i can reinstall my CAI?
 

·
Registered
Joined
·
132 Posts
I've heard of them but not sure.... There is a company www.pro-flow.com (248)541-4780 that makes an aftermarket MAF says it's for Zetec motors, not sure if they include the SVT in that or not (i'd bet not, however they might know if they are available).

I tried to call but I just got a whole bunch of ringing! Maybe your Stock one is jacked or you need to reset your system... Unplug the negative battery cable... Let sit 15 minutes or more, Plug back in, start car... It should have the speedo and tach freak out. Then it reset itself and learning over again...


now that I think of it, did you unplug your battery when you installed the CAI? If not then your car taught itself to run best with the stock set up on... you installing a cold air made it get a bunch more air... Kinda like you trying to stick your head out the window at 100MPH. Kinda hard to breathe... However if you live somewhere windy you figure out how to breathe!

Same concept! If you haven't already installed it with the battery disconnected try that. Might just have been your problem!

Good luck
 

·
Registered
Joined
·
842 Posts
Discussion Starter #5
ya i installed it with the battery disconected. It had that in the install instructions.
 

·
Registered
Joined
·
128 Posts
Why don't you want the AEM short ram? I just switched from the AEM CAI to the short ram and I can tell you (in this cold weather, that is) that I like it just as much. I had the short ram for my Zetec back in the day and hated it but I seem to like this one as much as my CAI.
 
1 - 7 of 7 Posts
Top