Focus Fanatics Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hello where can i buy a focus svt fuel rail pressure sensor as mine is broken. I can't seem to find one with the code: F8CF9F972BH which is from the focus 2.0 i suppose. I only see the sensor with code: 3R3E9F972AA which im guessing wont work.
 

·
Grey Friar
Joined
·
605 Posts
^X2. Stop guessing and ask the expert... Steve.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #5
Thanks for the replies, so Steve is the man to go for svt parts in general and/or for advice on troubleshooting any problems to svt?
 

·
Trump 2016
Joined
·
12,933 Posts
Yes and no. He works for Tascaparts ford. He can tell you where to go for parts that are not available for the svt.
 

·
Registered
Joined
·
12 Posts
I actually just bought a fuel rail pressure sensor from oreily's for my MK1 2.0, no issues so far. If you are in fact looking for a 2.0 version as OP seems to indicate.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #11
@ elizibeth , interesting just found out this frps is compatible with most ford, lincon, mercury cars/trucks. As i just swapped the one from my 06 f150 and the focus started. Guess ill check in with local autoparts stores to see if they got any in my area.

@ pasta, i guess i will not risk it and instead get a new one, as the two sensors from the junk yard didn't worked.($18) bucks for both.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #16
Car started up with new frps sensor, but iddled really high 1500- 3000 rpms and vibrated around 800-1200 rpms. Didn't moved car just started up 4 times and let warm up for 10-20 mins each time. Replaced broken vct solenoid, replaced fouled spark plugs with sp 463. Changed fuel filter, changed oil 5w30 and fl 400 filter. And now it won't start, just crank and wetting plugs again. It started on Monday before changing the vct solenoid, spark plugs and oil change.
 
1 - 16 of 16 Posts
Top