Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
ok for the past couple weeks my headlights havent been turning on

for them to turn on i have to flash my high beams like 10 times then they stay on but if i put my turning signal they turn off sometimes
 

·
Registered
Joined
·
135 Posts
Discussion Starter #3
bumpp ... .... ....
 

·
Registered
Joined
·
2,928 Posts
May be the multifunction switch. It is intergrated with the directional switch. Controls many things. Don't go to a dealer. Look for username b16sir1991 for pricing.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #5
should i buy hids for 150 installed instead of doing anything else ?
 

·
Registered
Joined
·
135 Posts
Discussion Starter #7
lol how do i do that ?
 

·
Registered
Joined
·
9,084 Posts
Well first you'd want to figure out what's wrong first as you'd probably experiece the same problem with the HID's. It sounds to me like it's a short in the wiring or a bad switch.
 

·
Registered
Joined
·
1,321 Posts
as mentioned above, looks like a faulty multifunction switch. purchase one off ebay, and install it yourself, a very simple fix. THEN, buy some HIDs.
 

·
Registered
Joined
·
1,467 Posts
the best quickest thing to do is to take it to ford and have them mess with it lol

and or talk to Mike(b16sir1991)

it might cost but it gets the job done with no frustration. i wouldnt buy hids, yet. untill the light issue is fixed. the hids will just have the same problem.
 
1 - 11 of 11 Posts
Top