Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
450 Posts
Discussion Starter · #1 ·
So I was driving around yesterday and all of a sudden my car just shut of while I was going up a slight hill. Almost made it to the top. So I try to restart the car and nothing, just keeps cranking. Kept trying to start for a couple more minutes but would just keep cranking. I wasn't far from home so I walked home to get some tools to see if I can diagnose the problem. Well after about 20 minutes I returned and went to go start it up again and wham! It started right up just fine. It was very hot out yesterday and right before the car stalled i had the front up on jack stands doing some brake work (don't know if these are potential problems). My brother says it's the fuel pump but I just want to be sure before I go replacing it. What do you guys think the problem is? I'm not diving the car anymore because I don't feel like getting stuck somewhere. But I don't know if this is just a one time thing or if this is going to happen every time I drive the car. I don't want to find out though lol. The car is a 2000 spi automatic. Thanks guys
 

·
Registered
Joined
·
228 Posts
So I was driving around yesterday and all of a sudden my car just shut of while I was going up a slight hill. Almost made it to the top. So I try to restart the car and nothing, just keeps cranking. Kept trying to start for a couple more minutes but would just keep cranking. I wasn't far from home so I walked home to get some tools to see if I can diagnose the problem. Well after about 20 minutes I returned and went to go start it up again and wham! It started right up just fine. It was very hot out yesterday and right before the car stalled i had the front up on jack stands doing some brake work (don't know if these are potential problems). My brother says it's the fuel pump but I just want to be sure before I go replacing it. What do you guys think the problem is? I'm not diving the car anymore because I don't feel like getting stuck somewhere. But I don't know if this is just a one time thing or if this is going to happen every time I drive the car. I don't want to find out though lol. The car is a 2000 spi automatic. Thanks guys
get something to test for spark and a can of starter fluid....next time it will not start test for spark and fuel......also if you have a code reader/scanner check for codes....sometimes you can catch a pending code
 

·
Hatch Nation #136
Joined
·
2,043 Posts
Are you up to date on all of your scheduled maintenance?

How many miles since your last fuel filter?
 

·
Registered
Joined
·
450 Posts
Discussion Starter · #4 ·
I don't want to wait till it happens again though. I was lucky enough that I was within walking distance to my house this time, and that it actually started back up after it sat for about 20 minutes. I don't want it to happen when i'm 50 miles from home and then my luck it wont start and i'll be getting it towed.

All maintenance is up to date. The fuel filter hasn't been changed in about two years though. its been at least 45k miles.
 

·
Hatch Nation #136
Joined
·
2,043 Posts
Well, change the fuel filter either way. Even if it doesn't fix it you are way past time.

Have you exhibited any other problems? Stuttering under load? Terrible idle? Bogging coming up to lights?
 

·
Registered
Joined
·
450 Posts
Discussion Starter · #6 ·
No other problems. Just a little surge while cruising every now and then, which I believe is the dpfe sensor
 

·
Hatch Nation #136
Joined
·
2,043 Posts
I am leaning towards it being a fuel related issue, but it is unusual for something like that to just fix itself.

It could be an electrical issue, cause they are known to be patchy.

I'd say get a buddy to ride around following you and see if you can replicate the problem. That way he is right there with you when it craps out and you can pay better attention to any symptoms as it is happenning.
 

·
Registered
Joined
·
228 Posts
I don't want to wait till it happens again though. I was lucky enough that I was within walking distance to my house this time, and that it actually started back up after it sat for about 20 minutes. I don't want it to happen when i'm 50 miles from home and then my luck it wont start and i'll be getting it towed.

All maintenance is up to date. The fuel filter hasn't been changed in about two years though. its been at least 45k miles.
No other problems. Just a little surge while cruising every now and then, which I believe is the dpfe sensor
you are doing what my Wife does to me everyday......she will have/create a problem and then throw up so my conditions and situations that it becomes impossible for me to solve the problem......I think she enjoys the entire exercise

You have what appears to be an intermittent problem.....I don't know of a logical way of solving it until it arises again....other then checking for codes and doing a fuel pressure test.....Maybe try moving it around on your property and see if it acts up......You could you go the illogical route

1) start throwing parts at it, fuel pump, relays, ignition switch, fuel pressure regulator, ecu, etc....
2) bring it to a Stealership and let them drive it around until it acts up
 

·
Registered
Joined
·
450 Posts
Discussion Starter · #9 ·
Well I figured the problem out. It was my Crankshaft Position Sensor. $12 fix and has been good for the last week.
 
1 - 9 of 9 Posts
Top