Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
195 Posts
Discussion Starter #1
I and my friends complains about "not bright enough" high beam thingy..
I got the Projector and installed and everything right, and seems like dual lamp cannot be turned on same time..I can hold high beam switch and all of them turns on but if I pull the high beam thingy, headlight turns off and only high beam thingy turns on..
Is it common by focus??
Or should I get it fixed or modify it??

If it is not possible to do anything with it, I better get the HID thingy..
Cannot see well with high beam in dark place..
 

·
Registered
Joined
·
515 Posts
This is normal for the Focus. To change it, you must modify. If you do a search, you may find instructions on how to do this, I just don't know them right off hand.
 

·
Registered
Joined
·
798 Posts
hi-beams are bright enough for me. I can see all the deer and little critters in the woods. Scares anybody else that is in the car, because they are afraid one of them is come out into the street. you really don't need the low-beams on with the hi-beams because you don't need to see directly in front of your car. The hi-beams illuminate everything except maybe 1 foot in front of your car
 

·
Registered
Joined
·
195 Posts
Discussion Starter #4
Hmm, then screw all ebay projector..haha
I got it from ebay, and that might be the problem..
Thx~
 

·
Registered
Joined
·
10,024 Posts
you have the projectorz? theres you reason the made in china is showing, if yuo want the highs and lows on at the same time you have to remove the stering wheel cover( on the top of the back of it) then on the left behind the headlight switch theres a plug, unplug this and look at the #s on the back of it where the wires go in, then you must jumper or cross the wires x and x, IM LEAVING THE #S BLANK TILL IM FOR SURE, i have this done and it works fine, im pretty sure its 8 and 9
 

·
Registered
Joined
·
891 Posts
yeah you have to do some wiring...then both of the lights will be on. When i had em I bought some 100W offroad bulbs and put em in my highbeams....it got much bright
 

·
Registered
Joined
·
2,191 Posts
if this high beam is a problem for you, then get some HID kit.... and that will fix the whole problem...:)
 
1 - 8 of 8 Posts
Top