Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
17,167 Posts
Discussion Starter #1
More garbage. Bought a Westar branded passenger side engine mount a little while back as they advertised on Rock Auto it was all rubber and not hydro type mount. On getting it looks identical to all others and a red flag then. Well, on car it began to rattle within 24 hr. and got worse and worse. Having tensioner issues today, already pissed off at car, let's see if I can make that worse. Westar to the rescue there. I cut the top bladder out to find the mount is a hydro one as I suspected and full of fluid. Went back to box and clearly marked solid rubber there. What liars! It rattles so bad the whole neighborhood knows when I come down the street. Maybe one month old now. I wanted to try a solid mount but was ready in case anyway, I will be converting this one as I have others to work much better without buying a new mount. It seems you can't take anyone's word for jack any longer...............

WESTAR, BUYER BEWARE!!!!!!!!!!!!!!!!!!!!
 

·
Registered
Joined
·
17,167 Posts
Discussion Starter #2
You guys pretty much know the rules by now, it's the Ford OEM pass side mount or nothing. I however choose to commonly take one of the crap mounts, install a stud in the top once guts are blown out and then add more rubber up top to make a cheap mount that can last quite a while, they can be pretty close to vibration proof as the OEM if done right. Don't even think about it unless you have at least a drillpress to drill the hole deep and correctly.

JIC anyone wondered why I'm messing with garbage parts.
 

·
Registered
Joined
·
17,167 Posts
Discussion Starter #3
Wouldn't you know it, the mount rattling pretty much DISAPPEARED when I cut the bladder to let all the fluid out of it. Now that's just too d-mn funny.............
 
1 - 3 of 3 Posts
Top