Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
321 Posts
Discussion Starter #1
I took my "03 SVT in this morning with 2200 miles on it for what I thought was going to be addressed by the TSB thread posted in this forum. I also had a check engine light that has been on for about 10 days, and the noise coming from the tranny that some have blamed on a T/O bearing or incorrect assembly of the clutch.
When I went back in this afternoon, the service writer tells me that the car has a European prorocessor in it and they can't do the appropriate diagnostics. Then he tells me that they have had SVT or something like it on the phone all day trying to diagnose the problem which turned out to be a no. 4 cyl. miss. They even went so far as to pull another SVT off the lot to cabbage parts off of. None of this worked. Not the injectors, not the wires, not the plugs.
[:(]

It really gets good when he tells me that SVT has been completely swamped recently with Focus problems and his guys didn't even get to talk to an SVT rep. They were passing messages all day! The final verdict from SVT is that they had a bad run of valves, and the fix is to pull the head and replace the valve.[eek] I guess on the bright side, maybe I can get the dealer to give me the head for a day or two so I can clean up the ports
He then went on to tell me that SVT was swamped with Focus calls but they were for MANY different issues.
Anybody else getting anything even close to this answer? On the bright side the loaner car was not an issue.
Sorry for the long post, just trying to get out the info.[thumb]
 

·
Registered
Joined
·
425 Posts
Nope.............But when I took mine in specifically for the TSB the service manager tried to charge 60.00 for a diagnostic and then proceeded to tell me they could not update the PCM since it already had the latest update (RLA4)............so I laughed, got my money back, and left to go try my luck at a close-by SVT certified dealer who doesn't look at my like "deer in headlights" when I ask for a loaner or to "wash the ca'" lol

-Later
 

·
Registered
Joined
·
1,073 Posts
I just went in 3 days ago for the ECU update and no problem . At least nothing was said to Me anyways. I went in for a distorted windshield cowling which was replaced ....I agree about the T/C..
 

·
Registered
Joined
·
321 Posts
Discussion Starter #5
I've driven the car all weekend and no repeat of the check engine light. The theory was that the valve was allowing unburned fuel out and this was triggering the light. This is good. the dealer isn't going to pull the head after all. But why is SVT covered up w/tech calls? And what about the bad batch of valves? Finalley, how is the car after the update?
 

·
Registered
Joined
·
1,073 Posts
I'm doing 0-60 in 5.1 and the 1/4 in 12flat.... seriously I wasn't experiencing problems like some were posting. I only had it done to prevent having to go back later. Runs ok not much diff, Maybe a little cleaner acceleration from down low.
 
1 - 6 of 6 Posts
Top