Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
the engine warning light started flashing on my focus while running the car was chugging then the light stayed on can you help me please
 

·
The Librarian
Joined
·
13,116 Posts
First off, [welcome] to FocusFanatics.
(I wish it were under better circumstances though)

A "flashing" CEL is not a good thing.
It generally means something a little more severe than just a faulty O2 sensor or something like that.

If you have someone nearby that can read any of the error codes stored on the ECU, that would be the first place to start.

Did you have any previous "hickups" before this incident?
What exactly were the conditions when this happened?

BTW, I've moved your thread to the Technical Chat forums.
That's where to ask for this type of help. [;)]
 

·
Registered
Joined
·
3,737 Posts
Your need to get the code read with a code reader. MAny auto stores, such as AtuoZone, will do it for free.

A flashing CEL generally means a misfire, which should be repaired ASAP before it damages the Catalytic converter.

First step is to get the code(s) and post them here.
 

·
The Librarian
Joined
·
13,116 Posts
As penguin mentioned, many auto parts stores will read codes for free.
I don't know what places you have in your location, but it's certainly worth a phone call to see if any of them will provide the service.

I hate to say it, but you really don't have much of a choice (get the code/s read).
We're basically at a loss to help you, until we find out what the computer says is wrong.

It could very well be bad gas, but if it were me I'd rather not guess.
Just in case...
Is it a reputable company where you bought the gas?
They didn't just get the tanks filled up did they?
I never buy gas from a station that has a tanker truck on the premises filling the tanks.
When they do so, it stirs up all sorts of crap from the bottom of the tank.
Best to move on to another station if that's the case.
 

·
Registered
Joined
·
94 Posts
If you got gas 30 miles prior, it could be a loose gas cap or you didn't put it on. I believe that's a code P0455. You're going to need the code posted if that doesn't help.
 
1 - 6 of 6 Posts
Top