Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I recently had the alternator replaced on my car and ever since then its had some funky electrical issues. I told my mechanic but he was only able to trouble shoot a few. Beyond that, I actually bought the car with a few funny electrical quirks and wanted to post here to see if anyone had solutions/diagnosis/DIY fixes. Im getting ready to sell the car and want it in as tip top shape as possible!

Heres a full list of issues:

When Bought
- passenger side windows will not roll down from the driver door window control panel. if you use the window buttons on the passenger doors, they work fine
- trunk button somewhat unresponsive, have to press multiple times/hard/or hold it down
- I think a CD is stuck in the CD player, since owning the car Ive never been able to feed a CD into the slot and I cant switch to CD option on radio

Since Alternator Replacement
- front windshield wipers dont automatically fire when I spray windshield fluid
- rear wipers wont fire at all, but fluid does work
- "door open" light always on

Looking forward to your responses and thanks for your time!
 

·
Registered
Joined
·
753 Posts
Window not rolling down from driver side could be faulty wiring or switch.
Trunk button needs to be cleaned or your car is one of those that only lets the trunk open when certain conditions are met.
Disassemble CD player and remove old cd. Could also try digging it out with pliers.
Rear wiper motor is probably dead. Idk about the front ones, could be multi-function switch going out. (The one you use to activate the wipers.)
Door open light, check the doors and trunk for damaged switch. Mine are behind where the door latches.
 

·
Registered
Joined
·
67 Posts
My rear wiper stopped working as well as the trunk release. I found its common in these hatchbacks for the wiring to break where it leaves the body and enters the hatch. Open your hatch and pull back the rubber boot and inspect the wires in there. I found a few broken wires in mine and just put a butt splice on each, everything works good now.
 

·
Registered
Joined
·
753 Posts
^^^ this too. I've not experienced this yet so didn't cross my mind.
 
1 - 4 of 4 Posts
Top