Focus Fanatics Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
264 Posts
Discussion Starter · #1 ·
02 ZX3 was just driving home in 4th gear around 50 or so... and the car just died... rpm's and mph just went to ZERO... car still had power though. BUT it wouldnt start... The starter dint even crank? Anyone know what this may be? Hopefully it's a easy fix... I just unplugged the battery 10mins ago to see if i can wait 1/2 hr to reset ECU... HOPEFULLY!

Also when i turn the key to on. Everything powers up... The miles i've traveled and trip show ---- -- - - - -- - on both lines.... can anyone help!?!?!


SMITTY
 

·
RespectMyAuthoritah!
Joined
·
7,105 Posts
sounds like the computer went to fail safe mode if you see ---- on the Odometer then that indicates a ECU error of some sort.....Maybe the battery trick will work maybe it won't......can't really offer much more advice than that, sorry.
 

·
Registered
Joined
·
264 Posts
Discussion Starter · #3 ·
advice is advice... anything helps... god i hate ECU's... the fiero was the easiest thing ever to work on... grrr silyl foci ecu... i hope it works... Talked to Tony rom New Edge and he gave me a list of stuff to look at... so im gonna go play realy quick
 

·
Registered
Joined
·
523 Posts
I would pull you computer out and check the connections. Is it throwing any codes?
 

·
my car breaks!
Joined
·
2,103 Posts
oh wait. i must have got mixed up, i thought you said the maf was the problem and the car was running now, jus that the CEL stays on after you fixed the MAF. i must have misunderstood
 

·
Registered
Joined
·
264 Posts
Discussion Starter · #12 ·
arg... MAF died like 2 nites ago... unonnected maf and it ran after like 15 cranks... ALT running area... ran it like that... cleaned the MAF after the code said it was the MAF ... um... but check engine light stayed on... something to do ith maf.. then it just died... all other power works though.


Smitty
 

·
Registered
Joined
·
1,067 Posts
check the various ECM fuses,and the ground connection at the ecm. Also check the little black w/orange strip wire that goes from the battery negative to the body of the car by the battery.
 
1 - 13 of 13 Posts
Top