Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
hello all...i have a 2008 ford focus se that has a rough idle and flucuating RPM's. i have replaced plugs and wires,cleaned up the mass air flow and ran injector cleaner.still the same.i have read that it could be the IAC valve that needs cleaned.i have also read where it is located,however i have yet to find it.does this year have one?i will be damned if i wouldnt be able to find it if i am looking in the right spot?any help appreciated...
 

·
Registered
Joined
·
17,175 Posts
It will be somewhere around throttle body as its' idle air passage bypasses the TB aircrack. Thinking may not be one there as well.
 

·
Premium Member
Joined
·
44,595 Posts
We need to know what year/model you are working on.

'08 does NOT have an IAC (electronic throttle body - "fly by wire" throttle).

It also doesn't have any plug wires, and you mention replacing those - so we can't be sure what you are working on.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
its an 2008 focus SE. 2.0. i just cleaned the connections on the "wires".it has a real rough idle to it and it has no check engine light on.i did have the car scanned for codes anyways but there is no code.
 

·
Vince your Moderator
Joined
·
5,074 Posts
Just what are the plugs gapped at?

You also may have a bad coil.
 

·
Registered
Joined
·
1 Posts
i am having the same issue. I looked all over my motor. then went to the junk yard to find one and broke that motor down to find it and still nothing. this is annoying as hell...and i have done all the same things changing out the plugs and coils and smoke machine
 
1 - 10 of 10 Posts
Top