Focus Fanatics Forum banner
21 - 23 of 23 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter · #21 ·
The turbosmart booster tee was installed.
The result is satisfying. It is like a mild first stage tune/remap (i guess it is about 130-140 hp).
It seems that it works fine, no issues, not too much pressure for the turbocharger and the engine.
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #22 ·
So even if it is set/turned one or two times could the turbosmart booster tee damage the engine?

If it damages the engine shouldnt there is a CEL? (Check engine light)
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #23 ·
The manual turbo booster valve was connected almost a month ago.

So far so good.

No issues. As the mechanic, the technical support and others said since there are no issues like CEL (check engine light) then it is alright and it should let it be as it is.

It seems to work fine on the third or fourth turn (click).



Performance is increaced. The difference is noticeable. Not very big. It was tested many times.



It didnt solve entirely the boost leak problem, again CEL turned on a few times when driving on a hil with 6th gear (a car shouldnt be drived like this, but it was done to be tested).

It turned on when the manual turbo booster was on zero (like when the booster is not connected, off) and when it was clicked (on).



Fuel consumption is still on normal levels (when it was remaped/tuned it was very high).



Generally manual turbo boosters are not recommended on ecoboost engines, but since there are no issues for now (after a month) and no CEL then it seems to be alright.
 

Attachments

21 - 23 of 23 Posts
Top