Focus Fanatics Forum banner

81 - 100 of 128 Posts

·
Torretto!
Joined
·
3,879 Posts
Mine was delivered Friday, they put notice in my mailbox but my wife didn't grab it when she got the mail..DOH! Could have picked it up Saturday! Oh, well... will have it Monday, yay!
 

·
Registered
Joined
·
4,283 Posts
You guys on the Facebook groups? There's a lot of people that are a lot more active on there.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
After ordering the transmission mount for my Auto transmission several weeks ago, I finally got around to installing it. I already had the Cobb RMM and TTR PSM installed for about half a year now so those were pretty well broken in. The new transmission mount was easy to install, took me about 45 minutes including jacking it up and taking that bottom cover off. It didn't add a whole lot of vibration and noise to my surprise. The one thing I do notice is this odd sound when my car is slowing down and coming to a stop with my transmission. Sort of like the clutch shutter but I just had that replaced (hence why I waited to install this) and had no issues with it. Anyone else notice a sound like this? And if it goes away. It drives great other than that sound.
 

·
Torretto!
Joined
·
3,879 Posts
Any complaints of people having this mount start causing a lot of noise, mine was fine until about 2 months ago and now it buzzes very loudly, both passenger and rear motor mount are upgraded as well..I haven't had a chance to remove battery and inspect it, but will do so soon, was torqued with torque wrench to specs provided in instructions. I am aware of some similar complaints about the TTR mount for the ST focus.
 
81 - 100 of 128 Posts
Top