Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter #1
I hope this is the correct forum, feel free to move it if not.

Ok, here's what happened. My Transmission mount snapped, which also sent the transmission into the floorboard cracking the transmission case, ripping the shifter cable away at the same time.

I know how to drive a standard, that isn't a problem never has been. They are claiming I was "Racing" or in "competition use", they also said that I did not operate the car correctly.

Here are the parts that I have added:
FORD racing plug wires
FFRP Underdrive pulley and gatorback belt
Bosal Cat-Back
AEM Shortram

Stock 16" ford wheels, stock suspension, NO chip, no forced induction, nothing else added and it hasn't even been on a Dyno.

So it looks like I will need a new tranny case and/or a new tranny, a VF mount and who knows what else. Two service managers and people who have SCCA raced their foci, said they'd never seen this happen.

Regards,
Keith (Sprintexec)
 

·
Registered
Joined
·
210 Posts
Discussion Starter #3
To find out how many, if any, other Foci owners have had this happen, the transmission mount just break. As well to figure out what my next steps will/should be.
 

·
Registered
Joined
·
2,807 Posts
sorry to hear about it. I have never broken the mount, although mine did loosen up considerably, causing it to clunk.

Is your car still under any sort of warrenty? and the service managers are denying you the work? If so, find another dealership, or a lawyer. and do you race it? can they prove it?

best of luck getting it sorted out.
 

·
Registered
Joined
·
210 Posts
Discussion Starter #5
Hello Norm..no, all I have is the aftermarket warranty, and after telling them I did not race it, and if they thought I did, they can prove it..they must have called Ford and asked how many have broken or been replaced, they agreed late yesterday that they would fix it, now I need it in writing.
 

·
Registered
Joined
·
723 Posts
That's a bummer. Hopefully it gets replaced under warranty. My mount was shot when I put my VF mount on. The rubber Bushing was really tore up.
 

·
Registered
Joined
·
210 Posts
Discussion Starter #7
The warranty company called me and said their parts people found a tranny with 16k on it (my hatch had 25k when I bought it). I should..I hope, have my hatch back early next week..I just wonder what else may have been damaged when the tranny broke loose...half shafts maybe?
 

·
Registered
Joined
·
149 Posts
I've been through two of those stinking mounts already (58,000 miles on mine). Bushing keeps pushing out of them.[mad]
 

·
Registered
Joined
·
3,174 Posts
If you let the aftermarket warranty company put in a used trans that they found, there is no warranty on that unit if something happens. I've seen that millions of times at work. They buy used motors and it starts leaking oil later. We call the aftermarket warrranty place and they say that they don't cover used parts....[???:)]
 
1 - 10 of 10 Posts
Top