Focus Fanatics Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello, I have a 00 sony edition focus with a zetec 2.0, ATX and the CEL came on, got it diagnosed as the tps sensor receiving low voltage. Idling rough *sometimes*, loss of power, general malaise...anyways I've been trying to find a new tps, Murrays and Auto zone can get it but I'm not sure it'll be the right one. The dealer I called said I need a whole new throttle body. I don't want to believe them...so does anyone have any advice or can you point me in the right direction to get this? I don't know a whole lot about engines so any help would be greatly appreciated.

also, do you have to calibrate it or anything before you put it on or is it plug and play?
thank you!!!
 

·
Registered
Joined
·
33 Posts
The TPS *should* be plug-n-play as long as you get the correct version. I'd scour eBay or call Tousley Ford. They sell at 10% over cost to the Focus world and Steve will definitely get you the part you need. I'm sure you'll find their 800-number around somewhere.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
The only problem I'm having is the 2 dealers I called today told me that I had to replace the whole throttle body and I couldn't replace just the sensor. I have a hard time believing that, seeing as how it's just two bolts and a connector. I guess I'll call around some more, I was kind of hoping someone could give me a part number from murrays...they have the ones listed for a DOHC but they don't specify if you need a different one for an automatic or a manual trans.
 

·
Registered
Joined
·
1,512 Posts
I've had some problems like that lately which haven't been resolved. I need to get the p/n off my old one and give it to Mike. He'll find the right one..

I'd lay odds that they're just trying to get some money from ya. Contact Mike, b16sir1991, and he'll hook you up with the quickness.
 

·
Registered
Joined
·
1,512 Posts
btw, has anyone seen this before?

The TPS on the left in the pics is from the factory. The one on the right is the one from auto parts stores and Ford dealerships on which the PN is YS4Z-9B989-BB. The part number on the TPS is slightly different, and what it says in the pic.





yeah, I know I need to clean my desk [:p]
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Well I'm just going to try and go the cheap route and order the one from autozone they say will work (wish they had a picture!) and do it myself (first time messing with my own engine). The guy reset the code today when i took it in to try to see if he could order the right one. I'll let you know what happens. Probably won't get it until monday or so. Is it possible if I keep running it like this that something majorly bad is going to happen or make the car not run at all?
 

·
Registered
Joined
·
1,512 Posts
The one you get from Auto Zone will look like the one on the right in the pics. Let me know if the plug fits..
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
man it sure doesn't look like it's going to go if I get the one that looks like the one on the right...we'll see what happens...murrays also has one from borg warner...no pic though, just says it'll work...is it me or does this just seem like a crap shoot?
 

·
Registered
Joined
·
1,512 Posts
It has been for me. Everyone else seems to have no problems.
 

·
Registered
Joined
·
1,512 Posts
Hm, maybe ford put the old one on my car from the factory?
 

·
Registered
Joined
·
51 Posts
The difference between the two is that the left one is for a 2003 model and the right one is 00-02 models, regardless of where you bought them.
 

·
Registered
Joined
·
302 Posts
hey manezinho, how did you get an Injen CAI for your focus?
 

·
Registered
Joined
·
42 Posts
I am having the same problem with my TPS sensor. I have been through THREE sensors (including one from Advanced Auto) trying to find the right one! I just sent my car to a mechanic and he said he thinks that you have to replace the entire TB from Ford that comes with a new sensor...
 

·
Registered
Joined
·
51 Posts
About the Injen CAI, I found it on ebay a long time ago, it's a racing series intake. Not CARB approved or anything but makes a beautiful noise and nice power at high RPM. About the sensor DO NOT BUY THE WHOLE THROTTLE BODY, IT'S STUPID. There's nothing wrong with your throttle body, but most dealers will only sell the sensor with the whole thing. It's really hard to break anything except the sensor on a throttle body, it's an excuse to make you spend 270 dollars, if you still believe you need a throttle body, I'll happily sell you my original one [:p] . If you go to Advanced auto parts, they have pictures on the computer when you order, that makes it easier.
 

·
Registered
Joined
·
76 Posts
blanezx3 said:
btw, has anyone seen this before?

The TPS on the left in the pics is from the factory. The one on the right is the one from auto parts stores and Ford dealerships on which the PN is YS4Z-9B989-BB. The part number on the TPS is slightly different, and what it says in the pic.





yeah, I know I need to clean my desk [:p]
the one on the left is for a auto and right is 5 speed
 
1 - 16 of 16 Posts
Top