Focus Fanatics Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
758 Posts
Discussion Starter · #1 ·
I just ordered the resistors and relay harness from theretrofitsource. But looking around the forum further I see alot of headaches people are having that I do not want!! Are the failures due to not using the correct equipment. Was it the hids that messed stuff up... I'm also not looking forward to mounting the resists permenatly to my car... might just have to send them back when they come in...
 

·
Registered
Joined
·
258 Posts
Just mount them in the engine bay or, let them hang like I did but making sure they have no chance of touching something that will melt. I've had HIDs for 3 years now and I can't go back. Never. Can't go back to those candles Ford provided.
 

·
Registered
Joined
·
758 Posts
Discussion Starter · #3 ·
Just mount them in the engine bay or, let them hang like I did but making sure they have no chance of touching something that will melt. I've had HIDs for 3 years now and I can't go back. Never. Can't go back to those candles Ford provided.
Ok thanks for the reply...so possibly those that are having issue didn't use the resistors? Hids and projectors are usually the first thing on all of our new cars... damn focus just had to be a pita to do it with... did you follow the install guide here? Have any pointers. They should be here Monday or Tuesday
 

·
Focus Preacher
Joined
·
3,417 Posts
You don't need the resistors with the mk3... you just need to change the Healight option with FoCCCus to Alternative HID and call it a day!
 

·
Registered
Joined
·
758 Posts
Discussion Starter · #5 ·
You don't need the resistors with the mk3... you just need to change the Healight option with FoCCCus to Alternative HID and call it a day!
Yes thanks again for the advice... however I don't have the know how to do that and wouldn't want to risk messing something up.. pretty cool thou
 

·
Registered
Joined
·
758 Posts
Discussion Starter · #9 ·
I use a Canbus kit and haven't had any issues. Basically plug and play.
I went to order that and the guy at trf said it wouldn't work and had me order the relay and resistors harness instead... idk might be getting into more than I first thought...I don't really want to mount resistors... I prefer plug and play
 

·
Registered
Joined
·
990 Posts
Mine were fine. I don't know what brand they are, but they have been working fine for over a month with no warning indicators or anything.
 

·
Registered
Joined
·
758 Posts
Discussion Starter · #11 ·
Damn!!!the ones retrofit had were mirimotos... probably would have worked... I might just try those first before installing the resistors.. can't see were I could just hang hot resistors from out of the way... Don't have them yet but I have a general idea of how big they are..
 

·
Registered
Joined
·
758 Posts
Discussion Starter · #12 ·
Just mount them in the engine bay or, let them hang like I did but making sure they have no chance of touching something that will melt. I've had HIDs for 3 years now and I can't go back. Never. Can't go back to those candles Ford provided.
Can you post a pic of were you hung yours??
 
1 - 17 of 17 Posts
Top