Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I been noticing that my throttle response is not all there and it seems im losing power. i was once able to do 125 Mph in 4th gear at about 5 1/2 Rpm. now im lucky to do 95 or 100. i also noticed that when i go from idiol then rev it up it pauses alittle and all you hear is the intake suckin air. so i checked the filter and cleaned it and made no difference. the powers jus not there anymore. anyone have any suggestions???

Thanks
 

·
Registered
Joined
·
456 Posts
There is a sensor called a throttle body space indicator it might be going bad, its smoe where near the tb either on it or next to it. Or the throttlespring may be going bad.
 

·
Shiroi kabocha
Joined
·
1,974 Posts
are you perhaps in the wrong gear? with the stock gearing i am going about 105 at 5500 rpm in 4th, and the 4.06 final drive lowers your top speed. if you said that you were able to go 125 at 5500 in 5th thats a lot more believable...

i would check the tps (throttle postition sensor), and if that isnt the case then you might have to consider getting a new throttle body.
 

·
Registered
Joined
·
42 Posts
fallacious_focus said:
are you perhaps in the wrong gear? with the stock gearing i am going about 105 at 5500 rpm in 4th, and the 4.06 final drive lowers your top speed. if you said that you were able to go 125 at 5500 in 5th thats a lot more believable...

i would check the tps (throttle postition sensor), and if that isnt the case then you might have to consider getting a new throttle body.
I agree...........

Have you checked inside your TB??? It could be very dirty causing the lack of throttle response... When I changed my TB to a FC 65mm, I noticed that my stock one was so dirty that I was ashamed that it was on my car........... try cleaning it and checking sensors first...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
perhaps i was wrong about the gear, i was almost certain of it tho. but fallacious_focus states his point well. ill post my Mph at 6000 Rpm for each gear and see what kinda numbers are coming up. maybe jus 3rd and 4th.

ill take apart the Tb tomorrow and clean it out. and get back to you.

thanks alot for the help.
 

·
Registered
Joined
·
170 Posts
Check your fuel pressure.Just a minor drop will affect your power.Remember,it's air and fuel that support combustion.
 

·
Registered
Joined
·
104 Posts
scorpio1118_2000 said:
There is a sensor called a throttle body space indicator it might be going bad, its smoe where near the tb either on it or next to it. Or the throttlespring may be going bad.
What?

Do you know what your talking about?

Its called a TPS(throttle position sensor) and it IS on the throttle body...

The spring or the sensor should not have major play here, as long as his car is idling good, I would put the blame on something else.
 
1 - 7 of 7 Posts
Top