Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Ok where to begin. so i first noticed problems on a long drive from tx to fl where it seemed like the engine would just miss or studder every once in a while. fast forward to now the car was shipped from florida to alaska and shortly afterward the check engone light came on. the code read out as tps, being in alaska two weeks later i finally got the part installed reset the computer and re-learned. worked fine...until it was shit off and restarted then the light came right back on for the same fault out of ideas i brought it to the auto hobby shop on base and they sent me to ford, saying only that they didn't know what was wrong other than the sensor was only getting 4 volts when it should be up around 5. the dealer ship said i needed a new throttle body (because they can't get just a sensor) and a wiring harness. being a skeptic i just ordered the wiring harness two weeks later again the part arrives and the damn thing isn't even close to fitting on the sensor i mean like square in a circle hole. ford swears it's the right part and says the throttle body must have been redesigned. so at this point a buy the story and order the throttle body. and wait....and wait.....and wait after many phone calls to ford the arrival date of the part finally comes go to pick it up and then they tell me it's back ordered and there's not even one available from any dealership anywhere. so I'm first on the list for one from the factory but who knows when that will be any ideas on how to get my foci back up and going good after market throttle body with the sensor included or something anything. sorry for the length but i had to rant somewhere thanks for reading and the help
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
aftermarket throttle body

my check engine light is on for tps and it was already replaced and the light won't stay off. ford says to change out the throttle body and wiring harness. the new harness they ordered for me is different than the original and the throttle body has been on back order for over a month. does any body know of a good reasonably priced throttle body and sensor combo. i should mention that the one problem that was found was that the sensor was only receiving 4 volts at wide open instead of five. any input on this problem or other idea to try would be helpful thank you
 

·
Focus Hoarder
Joined
·
3,633 Posts
Yup had the same problem with mine

the TPS you have is a slim model and is notorious for faulting so they revised the design.. I guess somone at ford said hey lets revise the WHOLE design and stick it to em

My quote was just shy of $650

I picked up a Throttlebody and TPS ( new style off these forums) went to the scrapyard and snipped the matching pigtail annd just patched it into my car and swapped out the throttlebody.. without even resetting the computer the CEL light went out and the engine ran beautifully

total cost
$75 for the used throttlebody with updated TPS
1 large double double coffee for the guy at the scrapyard as payment for the pigtail hehehe

Old style TPS


New Updated Style
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Went to the yard today and looked at three different tb/tps from '02 - '05 and they all look just like mine I've seen the harness for the redesigned one and it's not it. what exactly am i looking for here to narrow my results
 

·
Registered
Joined
·
1 Posts
tps issues

I cannot find a replacement tps for my 2001 zetec. part# xs2a 9b989 ab. saw on here that there is a way to attach a differ throttle body, sensor and pigtail. anyone have product numbers for them?
 

·
Registered
Joined
·
215 Posts
Just like to say, Include your VIN when ordering a Ford part, You'll learn that.

When you change the air filter, clean or replace the MAF. Most people buy CRC mass air flow cleaner - a special erolsol to clean the sensor wires.
 

·
Registered
Joined
·
17,163 Posts
If you have ATX they installed wrong TPS, it does not simply install and work right. There hasn't been an early ATX TPS available for a long while now. Now sounding like Ford has no more TBs either. They'd rather 'coerce' you into buying new car.

http://www.focusfanatics.com/forum/showthread.php?t=313092

Mine still running fine. Bear in mind you could have wiring-to-TPS issues too.
 

·
Registered
Joined
·
215 Posts
Mine said $387 plus $85hr lbr, plus diagnostic $325 and possible wire harness change out. $xxx.00
This seems pretty steep for a $500 focus, especially since we have $1800 in parts in it now, to honor mom who passed. I am wondering if I can make my own. (probly)
Maybe I can use the fuel sender from the module they replaced -said was bad. 12V to it and still pumps real good. (never made it home). This car loves to ride piggy-back.
 
1 - 11 of 11 Posts
Top