Focus Fanatics Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
Howdy all,

I've think I've got a problem with the throttle body on my 05 ST, possibly self-induced. A little explanation...

My car was suffering from the infamous sticky throttle pedal problem, so I decided to clean the TB. After a wipedown with a carb-cleaner-soaked rag failed to solve the problem, I removed the TB and blasted it out with carb cleaner, then gave it a rubdown with some 0000 steel wool to get rid of the residual crust that was left over. (Don't worry, I thoroughly cleaned off the little leftover steel wool bits.)

This fixed the sticky pedal but the car started surging. It would hang at 1,500-2,000 RPM when decelerating, then slowly return to idle speed. This behavior settled down after 1-2 days... but the MIL (CEL) came on. [:(] I got the code checked and it's saying IAC system, but I'm thinking it's a vacuum leak since I just put the car back together, and this would explain the surging.

Anyways, I pulled the TB off and realized that it's not closing 100%. There's an air gap visible around most of the throttle plate when you hold the TB up to a bright light. I'm wondering if my cleaning job was a bit too zealous and actually stripped some material off the TB and/or throttle plate and ruined it. [?|] I've never dealt with a plastic TB before, but this explanation makes sense to me.

BTW I don't think that messing with the throttle stop screw will help because the throttle plate is making partial contact with the TB, just not all the way around. IMHO adjusting it will just make the air gap larger. It really, really looks like the throttle plate is now slightly smaller in diameter than the TB.

Thoughts? Opinions? [dunno]

BTW what does a new TB typically cost? It seems from my brief time on this forum that they get replaced fairly frequently. [:(]
 
1 - 1 of 1 Posts
Top