Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,765 Posts
Discussion Starter #1
ok, i read it before in here, but i just couldnt find it... i have the TB stage II, but i notices that the rpms stay up around 2000 rpms and then slowly drops down to normal... give me a hand to find the thread with this info...

thanks
 

·
Registered
Joined
·
258 Posts
As I recall, the deal with adjusting the throttle body with the stock body at least, was that in cold weather the butterfly would stick in the plastic body, and the pedal would resist movement, until it would break free, and then it would work normally until you left it idle for a couple moments and it would stick again. The fix for that was to slightly turn in the small stop screw to crack the butterfly slightly more. That was necessary once on my 02, when I got the car. The IAC valve will still control idle speed, so there are no downsides to making this adjustment. The 2000 RPM cold idle, and hanging rev's when shifting are part of the stock SVT computer program, and part of it is probably a need for a fast cat converter warmup with the SVT header having it located downstream farther than normal. The answer on the web to the high cold idle speed and the hanging rev problem is always to "get a tune!". On my 02 SVT, I put a 50 cent flow restrictor in my IAC valve inlet port located next to the butterfly in my throttle body a few years ago and it fixed both those driveability problems.
 

·
Registered
Joined
·
11,906 Posts
It could also be a small vacuum leak............
 

·
Focused Focus
Joined
·
6,403 Posts
The way its adjusted, in most cases, is to unplug the iac, then idle the car to where its supposed to idle then hook the iac back up. You may cause a CEL, but just clear it off. You should set the idle while the engine has been warmed up, without the a/c on. Also, you need to remember that the car will actually have a learning curve it needs to go through if you just added this throttlebody.
 
  • Like
Reactions: HilloNative

·
Registered
Joined
·
1,765 Posts
Discussion Starter #6
i put the TB like 3 months ago, i at first i thought it was just the difference but im also skeptical about thing on the car, not because is a bad car it just experiences with another svtf ... but i will check for what you guys mention, vacuum leak, and try to adjust it...if i resolve my problems you guys are getting rep...thanks
 

·
Banned
Joined
·
7,946 Posts
Mike, if you unplug the iac while the car is running, it will shut off. also, it will not start without it plugged in. i went through this when i was troubleshooting mine.
 
1 - 7 of 7 Posts
Top