Focus Fanatics Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #1 ·
when in stalled my T/B i broke a small metal piece off the TPS =\ since then my engine light has been on. Also did everyone use antyhing to seel the gasket? My T/B is still sorta sticky the TPS is set in the right place for a 5spd MTX but i htink with the tiny metal piece i broke my car is'nt reading the T/B. So what is my car going through should i worry about?
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #3 ·
lol naw man. What i think i need to do is well first get diagnotics ran on my car cause i have an engine light on but also i did notice a slight hum when i idle so i bet the diognostics will show an air leak which means i need to get some gasket sealant and seal that gasket [;)]
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #5 ·
i pray it's a leak. Because if it's that little piece i broke off the 65mm T/B then i would have to get a new 65mm T/B and there is no way in hell i'll pay thatuch $$$ again so i would then port my stock t/B and go on my way
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #6 ·
guys what does the Throttle Position Sensor actually do?
 
G

·
Pretty much as it is named- tells the computer what throttle setting is currently being used (the throttle position). It is nothing more than a variable resister, but, without it, the computer will not beable to know what parameters to use for items like the ignition timing, fuel pressure, injector firing times, etc. Did the piece come off the TPS sensor itself? The sensor is replaceable. Also, if you do have an air leak, it needs to be taken care of soon since it will lean out the air/fuel mixture which can lead to burnt valves, toasted cat, etc. etc.

-JBFG
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #8 ·
if the problem was a broken TPS would my car be back fireing?
 
G

·
Not sure[???:)] , haven't had a lot of experience with a bad TPS, but a broken piece on it does not sound good. Sorry I can't be of more use.

-JBFG
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #10 ·
tommarow after school i'll ride up to autozone to have diognostics ran. If it's a leak i'll seal the Gasket it's it's the TPS i'll ut the stock one back on to make sure it's reallt the TPS and if it works fine with the stock then i guess i have $260 thrown away
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #13 ·
no it's not a leak i talked with mofocus in the chat room we are kinda undecided on what it might be but we know it's not a leak. So i have to go run diognostics on it it's the TPS i know it is. So if it is the TPS i then want to put the stock one back on and rest it and if the tps works with the stock one then i know i ****ed up the 65mm t/b which i would then probably break something. i dunno mo thinks that if the tps fits on the t/b nice and snug there shouldn't be a problem. Over all the t/b feels nice just that engine light isn't a good hting i just know it isn't lol that can usually mean money like that damn DPFE sensor
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #15 ·
well the problem was error code P0122 which mean bad connection to socket A of the TPS. That little tiny meatl piece i broke off was on the 65mm t/b it's self it's what gave connection to socket A of the TPS. So i put my stock t/b back on no CEL everything is cool. I'm talkign to myfordperformence right now trying to work out some deal maybe i can just exchange this for a new one.
 

·
Registered
Joined
·
10,022 Posts
dude like i told you last night

1) seal your tb w/ some black silicone or somthing
2)you need a new TPS
3) go ahead and port your mani
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #17 ·
i don't need a new tps i need a new 65mm t/b the peice that broke is on the 65mm t/b and lets the t/b talk to the tps. When i get another 65mm t/b i'll seal with black silicone and i'll port my mani. Just let met get this worked out with myfordperformence. Right now my car has the stock t/b on it and no engine light is on that shows that it's not the tps.
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #19 ·
lol it's not the long metal tube it was little flimmsey metal plugy type thing that was attached to the tb by thin plastic.
 

·
Registered
Joined
·
2,192 Posts
Discussion Starter · #20 ·
as soon as i find my digital camera i'll show u what broke off i don't think anyone understands what i'm talking about i'll take pics.
 
1 - 20 of 26 Posts
Top