Focus Fanatics Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I've been having problems with my break system for a while now. The first mistake I made was having my uncle, who is a mechanic on the side, change my break pads and rotors.

We could never get the breaks to pump back up. No matter how many times we bled the breaks, they wouldn't pump back up. We thought it might have been the master break cylandir, and replaced it to not much improvement. When I drove the car, I would have to pump the breaks a good 5 or 6 times so I could stop. Eventually, over 6 months, the breaks finally pumped up and have been working.

Now, ever since the breaks started working properly, and possibly before then, my breaks lights have been on, and stay on. I am afraid someone is going to plow into the back of my 2003 ZX3 at some point.

Is it just a sensor I need to reset? Any help at all would be much appreciated!
 

·
Registered
Joined
·
215 Posts
Your brake light switch may be bad (its on your brake pedel) not uncommon on fords. its easy to change ...unplug it and see if lights go out
 

·
Registered
Joined
·
220 Posts
Check if you bent the bracket that is suppose to touch the brake switch. Alot of times if you just bend it back a little bit the lights should go off i know i have done that plenty of times. but like ORANGE said it also may be your SWITCH which is a 15 dollar part and a piece of cake to change.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
DJ Lukdogg said:
Check if you bent the bracket that is suppose to touch the brake switch. Alot of times if you just bend it back a little bit the lights should go off i know i have done that plenty of times. but like ORANGE said it also may be your SWITCH which is a 15 dollar part and a piece of cake to change.
I'll check this in a few minutes on my next break. So, it seems that this switch is the only thing that controls your break light, and is completely seperate from your actual break system?

That is a bit of a relief.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
And after checking it seems as if the bracket somehow got bent. Now to go pry on it and bend it back to place!

Thankfully thats the only problem!
 

·
Bexar County
Joined
·
3,360 Posts
My parking brake light would come on for no reason because of a broke as master cylinder.
 

·
Registered
Joined
·
220 Posts
Glad to see you fixed your problem it commonly happens with me on the Brake switch recall on the taurues i bend it alot of times by accident and just bend it back. No biggy.
 

·
Registered
Joined
·
218 Posts
I bet it's not a "bent" thing...it's the switch.

The switches are like the old door jamb switches that come extra long. You install them and the pedal shoves the barrel in to the right length...like a round zip-tie.

Anyways...your uncle probably tried to bleed the brakes and pulled the pedal up farther than it would have normally travelled. The switch gets shoved in farther...then when someone isn't pulling the pedal up to the over-traveled position, the tab won't reach far enough to shut off the lamps.

You should at least pull the switch and uncompress it...they'll take it a time or two before they strip all the way...or just get a new one. You can tweak the tab or the pedal support to accomodate the tweaked plastic switch, but it would be kinda "Mickey Mouse" to bend metal stuff to fit a misadjusted plastic switch. Obviously, it's your call...
 

·
Registered
Joined
·
103 Posts
Same thing is happening with my 2001 zx3. The brake lights stay on when on drive, but when its parked they work..?.Also the turing signals from the back..i turn them on..either right or left. They both turn on and off..not at the same time..but more like a cop kind of thing..?
 

·
Registered
Joined
·
1 Posts
I just now got my brake lights stuck on, but I doubt that it is the switch.
I was trying to hook up trailer lights to a new trailer and something must have shorted. I never had a problem untill this wiring fiasco. I disconnected the trailer hook up but those brake lights still run with the ignition switch on.
Any suggestions?

Doh!! It was the switch! and the easyist fix I ever made! It must have been stuck on for about a week, cause that is how long my cruize control was out for..
Jeez I am mortified..[paranoid] But thanks guys!
 

·
Premium Member
Joined
·
1,653 Posts
My parking brake light would come on for no reason because of a broke as master cylinder.

I've heard of this being the culprit more than once.
 

·
Registered
Joined
·
345 Posts
Holy dead thread Batman!! LOL
 
1 - 13 of 13 Posts
Top