Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
115 Posts
Discussion Starter #1 (Edited)
since i installed the Steeda SRI, i noticed when i floor it on the highway until i hit around 100..My temperature gauge meter will eventually drop down to about 30-40% and the car feels much faster. Normally driving the meter stays around 45-50% Is this normal and is it ok for the motor??
 

·
w/ my magic bag
Joined
·
29,455 Posts
since i installed the Steeda SRI, i noticed when i floor it on the highway until i hit around 100..My temperature gauge meter will eventually drop down to about 30-40% and the car feels much faster. Normally driving the meter stays around 45-50% Is this normal and is it ok for the motor??
If thats all you did....I wouldn't worry 'bout it then....
 

·
Registered
Joined
·
115 Posts
Discussion Starter #5
Found out it was my spark plugs. I was using the AR103s, which are one step colder. Using oem now and they're fine.
 

·
Registered
Joined
·
1,070 Posts
My car does the exact same thing it has since day one. To me it's a good thing it could overheat instead.

Sent from my LG-LS997 using Tapatalk
 

·
FF Affiliate
Joined
·
30,764 Posts
Found out it was my spark plugs. I was using the AR103s, which are one step colder. Using oem now and they're fine.
The Autolite AR103 are what you should be running , any one that has issues with them 99% of the time they gapped then and the gap is over .065-.070

The wire is cut back and you have to be VERY careful how you gap then , you dont gap them the same as a conventional plug

To gap them you have to think about you measuring the closes point from the wire to the closest point on the electrode , with the wire cut back you totally have to change how you gap these plugs

The gains from these plugs are well worth the extra 3-5 Min to gap them correctly

Tom
 
1 - 7 of 7 Posts
Top