Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello. I have a 2008 focus s. recently the temp gauge climbs up to hot. just started happening out of the blue. I flushed radiator, put new coolant in it. I have great heat coming from heater, if i drive it with heat on low its fine in the city, on the highway after about 20 minutes it starts climbing, seams to b getting worse to were i've had to have heat on number 2 setting to keep it at normal operating temp according to gauge. radiator fan works fine, both heater hoses as well as top radiator hose gets pretty hot, hence i dont think its the thermostat. engine dont seem hot nor do's radiator cap, I can easily touch both. Radiator dont seem plugged, i can gently squeeze lower hose and c coolant move up and down in radiator. I have no coolant leaks. any thoughts? thx in advance for your helpful comments......
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
temp gauge

i know on older cars u cold take radiator cap off and see coolant circulating..is that still true on these focus's?
 

·
Premium Member
Joined
·
44,595 Posts
Should be possible on the ones with a radiator cap, many of ours have a remote reservoir so you can't on them.

Do you know if the low speed fan is working as well as the high speed one (both fans come on either slow or fast) ? A typical problem for many is when only the high speed setting is functional & fans don't come on until temp climbs high.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
my car only has 1 fan. it come on when ac is on, and when cars hot i raised hood and it was on.........
 

·
Registered
Joined
·
3,080 Posts
Thermostat can get stuck partially open, also i believe the pump has plastic fins you can lose a couple and not cool as well. I know you said low mileage but its the age that hurts these things and the fact that water/coolant is always on these items.
 
1 - 6 of 6 Posts
Top