Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
A few questions for the knowledgeable people here. What would cause the left speaker system to not work after installing a new Alternator? Also anyone else have to get their ignition barrel changed as well? Another issue is the car now will not have a clean sound when idling and sometimes slowing down, it kinda sounds like how a remote car would sound when it would slow down. I cleaned the air filter and it helped it for a day, so could it be a vacuum leak or a problem with the pcv pipe? Any help would be most informative.
 

·
Registered
Joined
·
3,174 Posts
The static noise you are hearing when you idle up and down is a bad ground somewhere sounds like. Do you have some sort of stereo system? Unless you knocked a wire loose or pinched one, the speaker should not just stop working. Check the wires to the speaker...you may just have a bad one. Do you have a spare one laying around? Try using a different one and see if you have the same results.

The Focus' are known for having bad ignition cylinders. Some people on here have had them changed more than once...try 3 or 4 times. It happens. Nothing you can really do to prevent it, just replace it when it happens.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
rough idling

well i meant that the engine sounds like its going to die when i stop and makes a sound not regular. it doesn't sound the same anymore, but the acceleration is there. this is the 4th time this year so far i had to fix something and its making me broke, any help would really help out please.
 
1 - 3 of 3 Posts
Top