Focus Fanatics Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
326 Posts
Discussion Starter #1
I want to swap out my cluster w/o tach to one with a tach. Which ones will fit the SPI? I have an 01'.
 

·
Registered
Joined
·
75 Posts
i might be wrong, but i believe its a plug n play type thing from any focus
atleast thats what it sounds like from the thread "the tach you never knew you had"
 

·
br/o/stang
Joined
·
5,563 Posts
I know theres a pin number difference between the duratec and zetec clusters (or at least the 05+?). Im pretty sure the spi/zetec clusters are interchangable
 

·
Registered
Joined
·
427 Posts
I swapped mine, and from what I found out by reading, clusters with a Tach on any foci from 2000-2004 should fit without any problems. THough I think the SVT ones dont fit.
BTW it is very easy to swap! 10 min max!
 

·
Registered
Joined
·
204 Posts
Buickboy is right. The clusters are interchangeable between the SPI and Zetec, except for the SVT cluster as louisgab mentioned. The Duratec's also use a different connector. I swapped out my cluster a few months ago for the KONA cluster. The KONA's are a safe bet because all of them are Zetec. I also prefer how they look over the standard cluster.
 

·
Jetsetter
Joined
·
6,654 Posts
yes plug and play, the only downside to this is that the cars mileage stays with the cluster, so if you want to do this you should find a cluster close to your current mileage, or less lol

and most dealerships wont program it for you, unless you buy it from them
 

·
Registered
Joined
·
575 Posts
The SVT one does fit the SPI i have one in mine and it looks great.
 

·
Registered
Joined
·
204 Posts
The SVT gauges go up to 160Mph and the standard focus clusters only go to 140Mph. I had heard that the SVT ECU was required for the speedometer to read the correct speed. But I guess that isn’t correct since you’re using one.
 

·
Registered
Joined
·
575 Posts
The speedo is off a little bit. When i'm showing 65 i'm really doing 60 but it's not to far off i just keep up with traffic.
 

·
Registered
Joined
·
75 Posts
with my stock spi cluster it shows im doing 65 when 2 different gps' says im doing 61-62...
 

·
Registered
Joined
·
427 Posts
The speedo is off a little bit. When i'm showing 65 i'm really doing 60 but it's not to far off i just keep up with traffic.
It's probably due to your tire size compared to OEM.
 

·
Registered
Joined
·
204 Posts
It's probably due to your tire size compared to OEM.
You’re right. Tire size does cause a difference. Although, when I first got my focus, the speedometer was off by 2mph and it still had the stock 14" steel rims on it. So when I thought I was going 55mph I was actually going 53. Then when I put my 16" rim on it got worse. I think it’s off by like 4mph now.
 

·
Registered
Joined
·
75 Posts
yeah i know... thats why i use my garmin for a speedo, my gps and dads are off by most a couple tenths a mph, and my blackjack 2 is within half a mph of both. so i trust the gps most
 

·
Registered
Joined
·
427 Posts
true, GPS shows the most accurate speed, its satellite and more precise than a cluster.
 
1 - 20 of 24 Posts
Top