Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an automatic, Ford Focus Ghia, 2005.

Recently the car has started to display a warning :

System Engine Failure - Transmission Malfunction

I have had this analysed and have been advised that the error code is

P0816 - Downshift Switch Circuit
.

There appears to be no problem with the main (automatic) transmission, only when trying to switch over to using the semi-automatic/manual selection, although this can sometimes work (almost) normally.

Has anyone else experienced this problem and can therefore advise me on a resolution. I’ve been ringing around various ‘professionals' and am so far less than confident in some of the responses I’ve received.

Thanks.
 

·
Registered
Joined
·
1 Posts
i also encounter this issue, when i turn the key to on position the display on the meter for the gear indcate start to blink , follow by the engine system failure and trnsmission malfunction then the immobilizer light in the meter starts to blink. after that the car fail to fire up some times, get my mechanic to reset and it starts fine but this repeat again n again at not fix duration. any advise to this issue. whats yr result on yr post and what is done to solve this.

thanks
 

·
Registered
Joined
·
1 Posts
I have the same problem, the car is at 86 000 km Focus MK2 Tourer 1.6L TDCi 109hp Durashift CVT '06 and it won't start on random basis.

I got the following codes with OBD-II:
U0073 - Control Module Communication Bus A Off
P0700 - Transmission Control System Malfunction

Any ideas are highly appreciated.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
After driving around with this issue for the last 2.5 years I decided to have it fixed.

We tracked the issue down to a faulty inhibitor switch on the external left hand side of the gear box.

Switch Part Reference : 7A247.
Cost of switch : £52 excl vat.

1/2 hour labour to replace the switch.
 

·
Registered
Joined
·
3 Posts
Hello guys,

I have the same problem on the same focus model, (2005, 1.6 ,TDCI, GHIA, automatic) the display shows me a transmission malfunction warning and I cannot find a solution.
So did you fixed the problem permanently by changing the inhibitor switch?
Do you have any diagrams of the gearbox or any important information regarding this fault and do you have some tips and steps to fix this fault.
I would be grateful for any answers
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Here is an image.

I had a mechanic replace it for me. It was easier for him to put it on a lift than for me to scrabble about underneath the vehicle.
 

·
Registered
Joined
·
3 Posts
Ok, so to be clear My focus on transmission malfunction sign, revs more than suppose to, sometimes it reaches the 3 bar and normal I used to reach the 2 bar. when trying to stop the car (applying brakes ) it doesn't realize that it needs to stop but you can feel the engine revs for 3 seconds.
when the transmission malfunction warning sign is present the gear leaver is hard to shift, if from drive is shifted to reverse or park the gearbox gives a bump, to avoid it I turn off the engine to reset and then I change gears.
Are these the same symptoms that you encountered ?

thanks again for your assistance
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
No, I had none of those symptoms, only those described in the OP and when setting the gears into the reverse position.

My advice would be to bye an ODBCII reader and plug that into the car to determine which error number(s) is/are associated with your issues.
 

·
Registered
Joined
·
1,193 Posts
A cheap OBDII reader won't give you transmission codes, though, just engine codes.

You might want to actually pay to get a scan done at the dealer's...I know, I hate paying for stuff like that too, but the scanner they use is brand-specific and worth thousands of dollars and will pinpoint your issue much better in most cases. Might well save you the cost of the scan in unnecessary repairs, too.

And it's not like you have to get them to do the actual repairs. Just get the exact code and full description so your regular mechanic (or you) has the right information.
 

·
Registered
Joined
·
1 Posts
ford focus 2007 1.6 zetec - Engine systems failure - transmission malfunction

ford focus 2007 1.6 petrol zetec - Engine systems failure - transmission malfunction

I've had this problem ever since I purchased the car (this year). Mileage is at 62000. Sometimes it happens as I try to start the car and sometimes the car starts fine. I've also had it say acceleration decreased as I'm driving the car, I pull over and turn the engine and ignition off, start it again and it goes back to normal. Not sure what to make of this but something is definitely not right. Sounds like a lot of us have encountered this problem, looking to find the best and cheapest way of dealing with the issue. Any advice would be greatly appreciated.
 

·
Registered
Joined
·
2 Posts
Hello guys,

I have the same problem on the same focus model, (2005, 1.6 ,TDCI, GHIA, automatic) the display shows me a transmission malfunction warning and I cannot find a solution.
So did you fixed the problem permanently by changing the inhibitor switch?
Do you have any diagrams of the gearbox or any important information regarding this fault and do you have some tips and steps to fix this fault.
I would be grateful for any answers
I've just bought a focus zetec climate, 1.6 automatic petrol, I had the same error message appear followed by "limited driving" couldn't do more than 2-5 mph but managed to get it to the garage I bought it from the other day, he said that he's 99% sure it's the transmission/gearbox oil that needs changing.

Have you had the issue fixed?
If so, what did you do?

Thanks.
 
1 - 12 of 12 Posts
Top