Focus Fanatics Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
762 Posts
Discussion Starter #1
Over the last few months, I've been refreshing the SVTF (It has 92,000 miles on it). New plugs, wires, cleaned the MAF, cleaned the air filter, new fuel filter, replaced the VCT solenoid, new timing belt, etc.

Anyway, the car has had an issue familiar to many SVTF owners, stalling when coming to a stop. Over the last few months, it's been getting worse and had gotten to the point where I could pretty much count on it stalling at least once per day and come close to stalling a few times per day.

One maintenance item I had not gotten to was cleaning the ground connections by the battery. I've owned two Mustangs, two Merkurs and two Focuses and I've always found that computer controlled Ford products can be sensitive to how strong the ground connection is in the wiring harness.

This past Saturday morning, I set about cleaning the three ground wires attached to the inner fender well just to the right of the battery. I used a wire brush and cleaned both the connectors and the bolts. While I don't believe this to be a cure all, the SVTF is running better, has a better idle and hasn't come close to stalling in two days.

So here is your Top Gear top tip...
Clean those grounds and maybe you won't have to be embarrassed at the next stop light when your SVTF decides to take a nap.
 

·
Registered
Joined
·
784 Posts
huh... i just might try that
 

·
Registered
Joined
·
762 Posts
Discussion Starter #3
Just an update. The car behaved for two weeks and started stalling again. Time for a tune.
 

·
Obama Can't Gymkhana
Joined
·
8,569 Posts
Sounds Like it ^^
 

·
Supercharged
Joined
·
3,275 Posts
Well the A/C can cause some problems if you don't downshift. If you depress the clutch and coast to a stop then you are more likely to get a stall.
 

·
Registered
Joined
·
385 Posts
Ya know...im at 96,xxx and I haven't had a problem with it stalling at all actually. What all have you replaced and whatnot?
 

·
Registered
Joined
·
762 Posts
Discussion Starter #7
I'm at 97,000 and the stalling just became a problem a few months ago. To date, I have replaced plugs, plug wires, IAC, O2 sensors, cleaned the MAF, cleaned the grounds and added a CFM 67mm TB.

The TPS and MAF are original, but the MAF has been cleaned multiple times using MAF cleaner.
 

·
Registered
Joined
·
762 Posts
Discussion Starter #9
I forgot to add that one. I had an MSD coil pack when the problem started and swapped back to the stock coil pack when I changed out the plug wires. It made no difference.
 

·
Dragon Warrior
Joined
·
309 Posts
Have you considered the Big 3 upgrade?

engine to chassis ground, battery to chassis ground, alternator to battery positive?

I did this a while ago and it helped my stalling problem. even with having an alternator that does not turn on until 1200 rpm.
 

·
Registered
Joined
·
385 Posts
I get light dim and when the stereo is on in my car it sometimes dims the lights a little. Has anyone done the Big 3 on their car to stop the stalling yet?
 

·
Registered
Joined
·
762 Posts
Discussion Starter #13 (Edited)
JRODSVT said that he did and that it helped. I got the cables made this afternoon and I'll put them on in the morning.

EDIT: I just installed the big three ground cables. I'll let you know how it turns out.
 

·
Registered
Joined
·
108 Posts
i had this problem but it was due to my o2 sensors being on for a month. (upstream and downstream) but when i replaced them, the guy who checked the codes told me to also clean the throttle body, MAF, and also the Idle control by taking out and spraying it down with carb cleaner. which is that part under the throttle body. its about 4 inches long and about 2 inches thick, has two bolts holding it in, one which is visible under the throttle body and on that is a little hard to get to. just my $.02.
 

·
Registered
Joined
·
762 Posts
Discussion Starter #15
^^I did all that and it didn't make a difference. The IAC is brand new. The car drove better, but it kept on stalling.

UPDATE: My first impressions after adding the big 3 ground wires are that it has made quite a difference. The car started easier, the idle is smoother, there is little or no surging, the car wants to rev more freely, the flicker in the dash board lights is gone and it hasn't come close to stalling!!!

I'll keep an eye on it and report back over the next few weeks.
 

·
Registered
Joined
·
385 Posts
Alright cool. Cause i think that mine is starting to act up. It was surging the other day but only for a few moments and i didnt think about what it could be. I thought gas or intake. but its prolly that! Post back up here and let me know how it goes. I will prolly have to do it soon and a great write up would be sweet! hahah [repost]
 

·
Registered
Joined
·
35 Posts
mine stalled 3 times within 3km. always in gear.
4th gear slowing into a corner
neutral at a stop sign and
3rd into my street.

what gauge wire am I using for the wire upgrade?
 

·
Premium Member
Joined
·
21,256 Posts
The last post in this thread (before yours) was 3 years ago. Hint: Look in the dark blue banner above the avatar. You're probably not going to get an answer. I highly suggest you ask the question in the SVT Performance Forum instead since you have an SVT.
 
1 - 18 of 18 Posts
Top