Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
296 Posts
Discussion Starter #1
Alright, I've been having this really weird problem with my 03 SVTF. When i've been driving along, the car will just die. no warning at all, the CEL, Battery Light, and TC Light comes on. theres no power at all. it was at the dealership for 2 days and they can't figure it out. I'm thinking its either the charging system or the fuel pump. the car just turned over to 25,000 KM.

anyone have the problem of their car dying at random times while driving. I have no mods at all done, but plan on getting an intake and tune very soon.
 

·
Registered
Joined
·
27 Posts
It sounds like the alternator is bad. It happened to my 04 at around that milage. The shop should have figured that out easily though.

Mine was replaced under warranty.
 

·
Registered
Joined
·
72 Posts
sounds like what was happening to me, died coasting to red lights, or while doing 30 in 4th gear, or at other completely random times. Battery light came on, then the check engine light, then it would die. I took it to Ford and they reflashed the ECU and that did the trick.
 

·
Registered
Joined
·
297 Posts
Poor engine ground. After I had the clutch TSB done, I would be driving down the road and it would just die .... same as you. Turned out they had not tightened down the engine ground good enough. They tightened it down and I have not had problem since.
 

·
Registered
Joined
·
364 Posts
alstud said:
sounds like what was happening to me, died coasting to red lights, or while doing 30 in 4th gear, or at other completely random times. Battery light came on, then the check engine light, then it would die. I took it to Ford and they reflashed the ECU and that did the trick.
Had the exact same thing happen for a month, never had it reflashed, it just went away on its own
?????????[???:)]
 

·
Registered
Joined
·
155 Posts
Do you have a K&N air filter?? Because sometimes the oil from the filter gets on the MAF sensor and burns onto the lenses and causes the pcm to take a sh** for a minute and stall. I had to replace mine and it works great now!
 

·
Registered
Joined
·
296 Posts
Discussion Starter #10
yeah i have K&N Drop in Filter, its never been over oiled since i've used it.

i've checked the engine ground, and i made a new one out of some 4 Gauge wire. its the short one, from the engine to the body on the passenger side.

at the dealership, the tech checked some relays and did something with them.
 

·
Registered
Joined
·
155 Posts
Yeah I had to buy a new one because the oil from the K&N air filter got on the MAF sensor and burned right on there. After that man I was good to go. Well...it's only stalled once since then but that's way better than before. SO yea I guess a lot of mechanics hate K&N air filters because of the oil so you have to make sure that it's really dry and then when you put the oil on only put a little and make sure it's really dry.
 
1 - 11 of 11 Posts
Top