Focus Fanatics Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Twice while driving my engine has died and then re-starts it self. All the dash controls fall to zero and right back up to operating positions. Upon returning home shutting off the car everything falls to a dead silence and dome lights don't come on. 5 seconds later the light appears and car will start. I cleaned up the battery terminals and car ran great for about a month and then it happened again.
ECU? if so it shows on eBay that the ECU is interchangeable with non-SVT focus models. Is this true?
 

·
Premium Member
Joined
·
1,625 Posts
Twice while driving my engine has died and then re-starts it self. All the dash controls fall to zero and right back up to operating positions. Upon returning home shutting off the car everything falls to a dead silence and dome lights don't come on. 5 seconds later the light appears and car will start. I cleaned up the battery terminals and car ran great for about a month and then it happened again.
ECU? if so it shows on eBay that the ECU is interchangeable with non-SVT focus models. Is this true?
First check all your grounds

1.) install updated alternator Pigtail 40$

2.) Install a new set of OEM battery cables 75$ ( they are known to rub and cause a short, They also corrode on the insude of the insulation where you cannot see)

3.) Install Updated Ignition coil pigtail 40$


I had this exact same problem you had, The alt pigtail helped quite a bit but the Batt cables were DEFINITELY the problem.... the ignition coil pigtail is also a common fault of misfiring so do it for preventive maintenance. Also only use the OEM alternator on the SVT all other aftermarket Alts BLOW BALLS.
 
1 - 2 of 2 Posts
Top