Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Sorry if this subject has been gone over before but I didn't even know how to search this topic with out needing a paragraph. Generally I am a lurker on the forum. I am able to search around find what I need without making a thread or posting anything. However I had a problem today that perplexed me. I have a 2003 SVT Focus EAP 110k miles

While starting my 52mile one way commute I had something odd happen twice. About 3miles into my drive at 6AM so it was dark, hi beams were on radio was going and I was traveling about 65mph in 6th gear. I then lost power all my dash lights came on RPM's dropped but lights and radio all stayed on. It was like I had turned the key to the ON/ACC position. So I shifted to neutral to coast of the road but all the dash lights went off and the RPM's came back and the car was running. I put the car back in gear and got back up to speed. About 3 minutes later same thing happened loss of power put the car in neutral from 6th gear and boom it was working.

Me being a stubborn male I decided to continue on since there was no overheating, no weird engine noises and no check engine light. I made it to work with no other issues. I am wondering if maybe due to a bumpy road maybe a battery terminal or some wiring may have came loose, but if it was the battery it should have still ran on the ALT. Also I find it weird that when I shifted into neutral that seemed to fix the issue? Sorry for the long post but I am wondering if anyone has dealt with this before and if there is a fix?
 

·
Premium Member
Joined
·
44,595 Posts
Unless the odo went to dashes instead of numbers, first guess would be bad wiring connector to the ign. coil (at least it's something to look at)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I dont recall if they went to numbers or dashes. I got to work and noticed my positive connector was loose on the battery so I tightened it down good and didn't have the problem on the drive home. Hopefully that was it, I guess time will tell.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Yea probably a good idea. I usually get stranded at least once by my cars. I guess I shouldn't buy cheap cars but I have a fever for the Foci and got my 1st SVT from a guy at work super cheap so I'm bound to get stranded at some point hahaha.
 
1 - 5 of 5 Posts
Top