Focus Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I recently did a SVT rear break conversion to my car. I have a 2009 SES with stability, traction control, and 4 wheel ABS. After the swap I took the car out for a test drive and the ABS, traction control, and break light(s) were on and the info center displaying "check break system," and none of the lights shut off after a 10 minute drive. My traction control also cut all power to my engine for about 60 seconds after I pulled out of the drive way on my second test drive (lasting 20 minutes). I bled the system a second time and went for a 30 minute test drive, and still had all the same problems. I have been bleeding the system with the Power Bleeder I bought off of FSWerks to aide in bleeding the system, and to reduce problems with the two person push peddle methoid . I'm leaning toward the problem being with the ABS sensors that are mounted next to the rear spindle. Is anyone knowledgeable about/with the SVT ABS system and rear spindles? Any help would be much appreciated!!!
 

·
Shiny Metal Titanium
Joined
·
3,647 Posts
Did you install it yourself?
I remember there being an ABS ring that you have to put on when the spindle/hub went on
I had a pic somewhere but don't know where it is right now.
It's just a simple metal ring. I don't have ABS or traction so I just left that piece out1
 

·
I.S.A.I.K.I.
Joined
·
5,413 Posts
Did you install it yourself?
I remember there being an ABS ring that you have to put on when the spindle/hub went on
I had a pic somewhere but don't know where it is right now.
It's just a simple metal ring. I don't have ABS or traction so I just left that piece out1
^What he said. You need to go back and make sure that you put your ABS rings back on.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Thats what that is. No, I didn't install it. I just rechecked the directions form Ford, I completely skimmed over that step. Which way does the ring slide on? Does the black strip face toward the inside of the vehicle (facing the sensor comming through the back of the spindle), or toward the outside of the vehicle?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
Does anyone know if the ABS ring get pressed on, and can I use a vice to do it? Also how far does the ring need to be pressed onto the hub?
 

·
Shiny Metal Titanium
Joined
·
3,647 Posts
I think it just goes on, I am unsure which side but you can usually figure out which way it goes on
I don't think you need to press that in there with a vice.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #8
I actually did need to press it on with a vice. Tapping the tone ring with a hammer started only bend it and didn't evenly apply the tone ring to the hub. So I took a round metal ring that fit the out skirts of the tone ring and put them both in the vice. When I reinstalled the hub with the tone ring their was about enough room to pass 2-3 sheets of paper between the ring and the sensor.
 

·
Banned
Joined
·
589 Posts
I recently did the whole SVT brake swap on my sedan and was able to slide the read ABS tone rings on and off pretty easily. Just a little nudge from a flathead screwdriver to get them off, and a little tap from a rubber mallet to get the new ones on.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #10
I recently did the whole SVT brake swap on my sedan and was able to slide the read ABS tone rings on and off pretty easily. Just a little nudge from a flathead screwdriver to get them off, and a little tap from a rubber mallet to get the new ones on.
I couldn't tap the rings without them becoming warped.
 
1 - 10 of 10 Posts
Top