Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
FocusXtreme
Joined
·
2,280 Posts
Discussion Starter #1
I was getting alot oil in my piping and intercooler,
because of the hose that runs from the valve cover
back into intake piping before the turbo.

I installed a catch can and it was working well.
Drove to work today stop at subway started the car up drove out to
the street and it started smoking like a dragster doing a burnout.
drove about 1mile and it stopped.My pvc line is still hooked up where it belongs
back when it idles I notice the hose that goes into my intake is collapsed.

Any ideas[8]
 

·
Registered
Joined
·
4,602 Posts
use a hose clamp or wire tie to force the hose back in to form but only use this temporarily
 

·
Focused Focus
Joined
·
6,403 Posts
Check my gallery for the type hose they are talking about, you can see it on the Procharger pic
 

·
FocusXtreme
Joined
·
2,280 Posts
Discussion Starter #6
ok so I capped off the plug on the back of the intake and ran the pvc hose and hose from the valve cover to my catch can.I was blow boost into my motor blowing oil out.

All is good and it runs and idles better[:D]
 

·
FocusXtreme
Joined
·
2,280 Posts
Discussion Starter #9
Well today I was driving stopped at bank andlook behind me and there so that white cloud again.WTF now so I pulled over tghinking now my catch was full but it wasnt and everything was quite,then it hit me so I winggled my oil pump timer and my pump kicked on.(Percision kit)

I was like son of beach,thats what it was the whole time.The timer was going on and off by itself,I have it set to run 45 sec after the motor turns,so my turbo was just flooded with oil.[:0]
 
1 - 9 of 9 Posts
Top