Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
So, here is my problem. About one year and a half ago, my car stopped shifting from the 3rd to OD. I took it to the mechanic and they found out it was shift solenoid C that’s stuck and they replaced it. It was all fine until two months ago when my car again stopped shifting from the 3rd to OD and check engine light turned on. I checked the code and it was shift solenoid C stuck on off. This time I was not ready to pay $800 again to get it fixed, so I changed solenoid and flushed transmission myself. It was fine for about two weeks and then again it started stucking in the 3rd. Most of the time it is OK and it shifts fine to OD. What I noticed is that it gets stuck in the 3rd when I’m trying to accelerate when going uphill. The problem is that after that, when I get to the flat road, it stays there and won’t go to OD. Then, the day after, it is all fine again. The car is also noisy in P and R, but this only happens in the morning when it’s cold and until it heats up. Any guess what it might be. I would appreciate any suggestion. Thanks.
 

·
Registered
Joined
·
872 Posts
This sounds like it may be a sensor problem or an associated electrical issue. The tranny, I'm pretty sure, has a speed sensor (or two), one of which could be the culprit, but other sensors or components could be involved as well. Has the SES or OD/tranny light ever come on? The noise in P and R.......is it a whine?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
There should be two speed sensors, input and output. Any idea how can I check them? I am not getting any code for them. The only light that was on is check engine light but that one turned off after I changed the solenoid. OD light goes on only if I push the switch on the gearshift. The noise on P and R is more like rumbling and vibrating.
 
1 - 3 of 3 Posts
Top