Focus Fanatics Forum banner

1 - 17 of 17 Posts

·
Premium Member
Joined
·
44,595 Posts
Discussion Starter · #1 ·
I'm "stuck" here.

just HOW do you separate the dipstick tube from the oil pan on a Duratec 2.3??

[???:)]
 

·
Premium Member
Joined
·
44,595 Posts
Discussion Starter · #3 ·
mine just pulled out when i dropped the pan
Mine is nicely rusty, it SEEMS to want to separate at the small tube to "bell shaped" steel piece that sticks into the pan, but neither joint is coming free....
 

·
Premium Member
Joined
·
44,595 Posts
Discussion Starter · #5 ·
WD, pry, wiggle, tap, bang etc. - try again tomorrow....

BSD kit from the "fest" was just sittin' there tempting me to install it.....
 

·
Registered
Joined
·
106 Posts
oh yes just did mine sunday thats weird mine came out with just a lil work. Do you have all oil pan bolts loose and pryed loose from block?
 

·
Registered
Joined
·
1,380 Posts
if its anything like the one on a zetec i had to soak it, pull twist. ended up bending the shit out of it. eventually i got so mad (2 days trying to get it out) with it i just grabbed it and started pulling it as hard as i could and after slamming it up and down 2-5 times it popper out and i ended up on my ass. put in the svt stick i made sure to put a little bit of anti-seize on the end and then once it was in i drained to oil to get rid of anything i knocked loose.
 

·
Premium Member
Joined
·
44,595 Posts
Discussion Starter · #9 ·
Pan itself is fully unbolted & loose from the engine, going out in a couple to give it another "wiggle", maybe a few hours of WD soaking will have helped....

Thanks...
 

·
Premium Member
Joined
·
44,595 Posts
Discussion Starter · #11 ·
Well, the bloody thing is at least wiggling now, STILL won't pull out..... (grumble)

And I'll try the "blaster" as well...
 

·
Premium Member
Joined
·
44,595 Posts
Discussion Starter · #13 ·
Success!!!

CRC Freeze Off, with repeated applications, Plus wedging a plastic hammer to pull on the dipstick tube (basically hold it in place), while prying the pan down at an appropriate point to avoid damage... Plus "wiggling"....

It's FINALLY off so I can proceed with cleaning, removal of the balance shaft assy., install of delete kit, and get it all "back together"!!!

Thanks for the replies, wanted to make sure I wasn't missing something "obvious" to someone who had been in there before!
 

·
Premium Member
Joined
·
44,595 Posts
Discussion Starter · #15 ·
Hey Predator - it was all worth it - All that weight off the nose, and the engine spins up MUCH quicker - feels a LOT more "Spunky"....

Won't know the REAL performance improvement 'till I take it to the drags, but it feels MUCH better, AND the "vibration" is just enough to know there is an engine up there, instead of wondering if it's even running.... (grin)

I assume you had the same good results with yours....

Cheers!
 

·
Registered
Joined
·
106 Posts
yes i enjoy it but i could always no it was running causa my exhaust. as for vibration i did this and the poly dog mount at same time. its only noticeable at stops, feels great running up to redline though. Whats next on your mod list?
 

·
Premium Member
Joined
·
44,595 Posts
Discussion Starter · #17 · (Edited)
Need poly bushings for the stock rear bar, or I might just go to the SVT one WITH the bushings....

And the "Dogbone" would be good at this point, though I don't NEED it yet...

Can't decide yet between "Rally" brakes or the full SVT setup, sold my all seasons off the stock 15's so I could get GOOD winter tires...

The "Rally" kit would probably be best for my setup, want to upgrade to the '05 swing arms with the larger pins at the same time.

BUT for now, cheap mods. will have to do....

Cheers!
 
1 - 17 of 17 Posts
Top