Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2005 2.0 zetec M/T. When i am cruising at part throttle, then engine bucks at times. If I rev the engine to about 2500 RPM's and hold the pedal there, the engine RPM will evetually fall to about 1300 and slowly rise again. I have no codes and the check engine light is not on. The car is well maintained. I also have a OBD2 bluetooth scan tool and the torque app. Fuel pressure according to the app is just under 40 PSI. Im thinking it is the fuel pressure sensor on the rail. How can I verify?
 

·
Registered
Joined
·
15,428 Posts
You just did, the 40 thing and correct. Likely not that anyway.

Impossible engine, there were no zetecs in '05. Duratech only.

The cars commonly do not register codes on some things for a while.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
so I noticed that when I hit bumps in the road the problem was worse and when my fuel level was low, the issue was worse, I changed the fuel pump and now all is well
 

·
Registered
Joined
·
15,428 Posts
The problem seems to show enough for OP to mention, meaning the tank is often low at your house. I bring it up because running around very low on fuel a lot is one of the best ways to kill a fuel pump...............
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
I drive 150miles every day. So yes, I have below have a tank every other day. That being said, I have only owned this car for 10,000 miles
 
1 - 5 of 5 Posts
Top