Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
some times when i get in my car, it kinda goes VROOOM vroom VROOOOM vrooom, over and over, and if i give it a lil gas it will come back down and idle at 1.5-2 which, isnt normal..

if i turn the car off, some times that fixes it, some times it doesnt, some times it gets a lot better some times it gets a lot worse...

any one know whats going on?
 

·
Registered
Joined
·
73 Posts
Discussion Starter #4
well it did it this morning, when it was cold... but it also has done it at 230 in the afternoon when its warm... so yes and no lol
 

·
Registered
Joined
·
24 Posts
it could be your tps or you could need to adjust the idle. also it could be sparkplugs or wires. could even be ur clutch/throw=out bearing
 

·
Registered
Joined
·
245 Posts
Does warm (230 in the the afternoon, mean the engine is warmer, as in the engine is above 240 degrees) or something else
 

·
AKA Toyotech
Joined
·
4,043 Posts
probably a clogged iac. it dop 250-300 rpm here and there?
 

·
Registered
Joined
·
73 Posts
Discussion Starter #8
dont know what a tps is, dont need to adjust the idle cause its only doing this some times.. dont know what an iac is and dont know what you mean by dop 250-300
 

·
AKA Toyotech
Joined
·
4,043 Posts
tps, throttle position sensor...which it isn't, and you can't adjust the idle successfully. the iac stands for idle air control, and i mean the drop in rpm
 

·
Registered
Joined
·
73 Posts
Discussion Starter #10
not, its just when i turn it on, and it goes from 1-1.5ish with out any help from me, and it just goes up and down and up and down... hehe..


i think its possibly fuel injectors.. bought some cleaner, will see if that helps.
 

·
Registered
Joined
·
76 Posts
My car does that too when its cold out. But after the car warms up its fine. I have a race header and no cat. That might be why. I just give it a few revs after starting it to get the engine up and running. I just put on a set of ford racing spark plug wires and a set of autolite double platinums and it help on the idleing problem. It is now more responsive as well.
 

·
Registered
Joined
·
291 Posts
Maybe the cable came off the bracket on the throttle body...I had that happend to me did the same thing. But i just put in an intake must have bumped it in the process.
 
1 - 12 of 12 Posts
Top