Focus Fanatics Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter #1
Here is the deal. I have a fc 65mm throtle body. Over the last month or so my idle will hang at what ever it is at the time that I press on the clutch. But if I tap the gas petal the idle go's back to normal. I have narrowed it down to the butterfly in the throtle body is hanging open. It is like the spring is not strong enuff to close it. Have any of you had this problem and what did you do about it.
 

·
Registered
Joined
·
49 Posts
have you looked around the TB any and see if anything is getting in the way of it. And when you got it did it look normal like opend and closed fine????
 

·
Registered
Joined
·
82 Posts
Discussion Starter #5
I have checked around the throtle body and I have checked for the sticky pedal. No dice
 

·
Registered
Joined
·
49 Posts
i have never heard of the spring not strong enough for the trottle body to close or vicia versa....you could always contact the manufactuer and ask them if they had any of those promblems or anybody else for that matter.....or the spring could have gotten damaged when you were installing it some how...idk just throwing out some ideas for you [dunno] [?|]
 

·
Registered
Joined
·
958 Posts
talk to steeda...its the same bloody product but w a shiny new label [8]
 

·
Registered
Joined
·
1,512 Posts
a search would be a much better option. I did the work for him/her in my earlier post!
 

·
Registered
Joined
·
121 Posts
I have the same prob now. I just put mine in a few hours ago. Im guna call over to McNews tomorrow. Plus there is not enough tension in the throtle cable, like it needs to be shortened.
 

·
Sonic Mk3 Crew #03
Joined
·
1,842 Posts
Hey guys its simple just move the TPS Sensor to another screw whole trust me. you put it in the wrong place the three diffrent settings on there gets confusing just undo the screws and move it to the nearest hole if you have automatic move it towards the one thats farthest from the other screw holes on the Throttle Position Sensor its not the springs or any of that. if those of you that dont have a 65mm tb unplug the TPS from the harness and your rpms will not go down because the car has no idea that you realeased the pedal. If this dont work goto C-f-M.com to get a new TPS.
 

·
Registered
Joined
·
51 Posts
if your car is a 2003 then you could try flipping it 180 degrees, worked on mine.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #15
This is something that is getting werse as I go. It did not do this at first, so it is not the tps. Also when the throttle hangs all i have to do is tap the gas pedal to break it free and the rpms drop back to 750 or so. something is getting stuck. I am not at home and the car is in the garage for about three weeks. So I am missing my car.[scratch]
 

·
Sonic Mk3 Crew #03
Joined
·
1,842 Posts
Trust me its the tps i know for a fact i had the same crap happen to me just change its position
 

·
Registered
Joined
·
94 Posts
Has anyone had the sticky throttle body when the butterfly is closed on the Focus D2.0? This has been an ongoing issue with D3.0 and D2.3 engines (I came from an Escape board). Ford states to never clean the TB but a soft toothbrush and some Chemtool would resolve the problem for about 40k+ miles. I was wondering if the Focus had the same issue since it uses the Duratec family of engines.
 

·
Registered
Joined
·
82 Posts
Discussion Starter #19
Well I found the problem. No it was not the tps senser, on mine the tps will only go on one way. I will not bolt to another set of holes. I found that when the idle would hang that the butterfly was not closing. I could push the butterfly closed the idle would drop back. So I started to take the tb apart. I found that the o rings that are on the trottle shaft were dry. So I put a small amount of I temp grease and put the tb back together and all is good.
 
1 - 19 of 19 Posts
Top