Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
459 Posts
Discussion Starter · #1 ·
Just put the Steeda Rear bar on, and the bar seems to sit "off center" as compared to the tabs that rest between the mounting brackets.

The tab of one side of the bar is pressed against the bracket/bushing, and other sides has about 1/8" space between the tab and the bracket/bushing.

I'll get a pic up later today, but basically the bar is off center and pushes against one side.

It's also not blue like it is in the pics - not sure what I'm more upset about, the bar mounting or the "not blue" color...
 

·
Registered
Joined
·
985 Posts
post pics. Mine is center. I can post pics if needed.
 

·
Registered
Joined
·
459 Posts
Discussion Starter · #3 ·
I'll try and get them up in there later this afternoon - I'll holler at you for pics if a little re-adjustment doesn't "cure" the issue. Thanks boss.
 

·
Registered
Joined
·
83 Posts
When I installed a Steeda RSB on my Mk1, I had to make sure it was centered since there really wasn't anything forcing it to stay centered. It should tend to self-center a bit with suspension movement, but keeping it centered when tightening down the clamps is important. Hope this helps...
 

·
Registered
Joined
·
459 Posts
Discussion Starter · #6 ·
Elizabeth, real deal Steeda, straight from them.

SVT, I think I need to loosen, center, and re-torque the mounts, hasn't moved in the two days it's been on.

Wound up straightening up the garage tonight for the wife's car to make it back in, I'll get to it in the next day or two here, and I'll report back in.
 

·
Registered
Joined
·
459 Posts
Discussion Starter · #7 ·
So, got underneath it last night, loosened up the mounts, tapped it to center and retightend.

More importantly, however, is that my request for some Steeda stickers, in lieu of the blue stabilizer bar I was expecting, have shipped.

All is well.
 

·
Registered
Joined
·
459 Posts
Discussion Starter · #9 ·
I wouldn't worry about it. Mine did the same thing. I got underneath and re-centered it and it went right back. I have no problems.
Couple days in now, still centered; I think your brackets might be a little misaligned if it went back. First time I just moved the bar to center, then retightended, and it offset again.

I'd loosen it up again, use a big flat blade screw driver and wiggle it back and forth between the bushing/bracket and tab (on both ends), and then retighten. When I wiggled the SD in between as noted above and then tightened, it stayed centered.

Cheers.
 
1 - 9 of 9 Posts
Top