Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hello

I am having problems starting my car. I thought it was the battery so i went down to autozone and they replaced the battery because they said it was bad. However I am still having problems.

My dad said it could be an ignition switch problem, because when it is working the airbag light and battery light will come on and off...and the engine will like jump or knock really hard and lose power like it wants to stall. It stalls but sometime I can start it back up....sometimes it doesnt unless I get a jumpstart.

What are the symptoms of ignition switch problems?

Thanks

Kevin
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Another symptom I am seeing is that when I start the car (when I can) it will sometimes screech like it's started already but I haven't over cracked it.
 

·
Registered
Joined
·
40 Posts
Faliol here you go: http://www.focusfanatics.com/forum/showthread.php?t=253669

That's my thread. Car would always overbite no matter how careful I was with turning the key. New starter fixed the problem. Car had been overbiting for a few years.

Most importantly before this the car was acting crazy, lights flickering/not wanting to start/starting randomly. All this was due to a bad positive battery terminal. There is a Ford TSB on this issue. You have to check underneath the terminal for any corrosion. A LITTLE BIT OF CORROSION caused all these problems so don't discount it just b/c it looks meaningless. My wire had actually burned down a few inches a bit and was covered in blue mold stuff. Instead of buying a new harness I cut off the bad part and connected it to a new battery terminal clamp. Done and done.

If you've never done a starter before it'll take a while. I might have to redo mine again, this time I'd say total time would be 3hrs.
 
1 - 6 of 6 Posts
Top