Focus Fanatics Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
ok the problem is i JUST installed my new springs not even 12 hours ago...im getting alot of irregular squeaking problems and am kinda concerned...is this normal? and if so how long does it usually take for them to settle down?!
 

·
AKA Toyotech
Joined
·
4,041 Posts
spings aren't supposed to settle, if they do...then theres a problem with the springs. the creaking will be pretty much normal with the stock isolators or if they r not correctly seated.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Kicknzx3 said:
spings aren't supposed to settle, if they do...then theres a problem with the springs. the creaking will be pretty much normal with the stock isolators or if they r not correctly seated.
do u have sportlines on yours or just stuff you heard? what are stock isolators?
 

·
AKA Toyotech
Joined
·
4,041 Posts
don't have sportlines..and that doesn't make a difference. thats what lowered suspension will do on many cars, specially when its cool out. isolators r the rubber pc's that sit on the perch and rear spring at the bottom...helps eliminate friction and noise
 

·
Registered
Joined
·
1,247 Posts
Go chek and make sure the springs are all the way turned to the stop on the base if not redo it so that they do..I have sportlines and have for about a year. They never made a sound once..
 

·
Registered
Joined
·
793 Posts
yeah, the stock isolators may be the prob, you can get better ones at www.newedgeperformance.com , a friends zx3 has had some squeking also, mostly from the rear
 
1 - 9 of 9 Posts
Top