Focus Fanatics Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
300 Posts
Discussion Starter #1
Is this what the drivers side motor mount is supposed to look like? Or does it look bad?

 

·
Registered
Joined
·
16 Posts
not sure but it doesnt look good, how many miles do you have?
to check it rock the motor back and forth ifs its bad it will move a lot
 

·
Registered
Joined
·
300 Posts
Discussion Starter #4
not sure but it doesnt look good, how many miles do you have?
to check it rock the motor back and forth ifs its bad it will move a lot
80,000km (~48,000mi). The motor doesn't seem to rock when I push on it but it doesn't look very pretty. Can someone take a pic of their mount for comparison.
 

·
Focus Fanatic
Joined
·
7,252 Posts
Wow, that looks pretty rusty.....can't tell if the rubber bushing is good still or not though.
This is what mine looks like, but I upgraded.

 

·
Registered
Joined
·
3,118 Posts
Yes it's supposed to look like that. After all, it's not stainless steel.

What is the deeper question?
 

·
Aurelius Pardus
Joined
·
26,535 Posts
the miles are pretty low for it to go but it is possible you can allways pull it out and inspect the rubber to see if its broke
never run with a broken rubber...
 

·
Registered
Joined
·
1,231 Posts
Mine was split like yours and I replaced it with a new oem mount, just in case. Didn't make a bit of difference......
 

·
Registered
Joined
·
14 Posts
Hmmm

I was just told that I have 2 mounts that were bad. Funny too, cuz they seemed fine until I was in an accident that ruined my front suspension.

So, how difficult are these to change?
 

·
Registered
Joined
·
1,231 Posts
I was just told that I have 2 mounts that were bad. Funny too, cuz they seemed fine until I was in an accident that ruined my front suspension.

So, how difficult are these to change?
Really simple. I had a helper move the motor around for me for the transmission mount though..
 

·
Registered
Joined
·
1,410 Posts
Now if I upgrades all 3 motor mounts i will have no movement right, even under hard shifting?
 

·
Focus Fanatic
Joined
·
7,252 Posts
^^^^
Very slight movement, if at all. Can't exactly watch your motor under hard shifting though.
I've got all 3 on mine, and i remember seeing my engine start up when I had all 3 stock mounts, I couldn't believe how much the engine moved when it started, and now with all 3, it pretty much doesn't move at all when I start it, its amazing. There are tons of benefits to the poly motor mounts, so if you can stand a little bit of vibration at idle, then it'll be worth it to you. Its well worth it to me. One of my favorite mods.
 

·
Focus Fanatic
Joined
·
7,252 Posts
Lower mount is under the engine, drivers side is under the intake box,
passenger mount is to the passenger side of the valve cover.
 

·
Registered
Joined
·
77 Posts
Guys,
Where under the hood should I look for motor mounts. I was at the dealership last week and ask the guy to fix vibration, and he advised me to replace motor mounts. I drive 2000 SE w/ 125k miles.
 

·
Aurelius Pardus
Joined
·
26,535 Posts
Guys,
Where under the hood should I look for motor mounts. I was at the dealership last week and ask the guy to fix vibration, and he advised me to replace motor mounts. I drive 2000 SE w/ 125k miles.
read a couple posts up..... loudfocus01 just explained the same thing to me lol...
 
1 - 20 of 20 Posts
Top