Focus Fanatics Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
New member here. 2013 SE sedan w/ 6 speed manual. Car was running fine with no issues. Parked it and got in about 30 minutes later with all dash lights on, no power steering and no speedometer. Took to shop and they say it throwing codes for right front wheel speed sensor, left rear wheel speed sensor and the transmission speedo sensor. Also throwing a code that the front catalytic converters needs replaced. $2k bill from the shop. Have to fix it but concern is there may be a bigger issue causing all to go out at the same time. Anyone experience this?
 

·
Registered
Joined
·
203 Posts
New member here. 2013 SE sedan w/ 6 speed manual. Car was running fine with no issues. Parked it and got in about 30 minutes later with all dash lights on, no power steering and no speedometer. Took to shop and they say it throwing codes for right front wheel speed sensor, left rear wheel speed sensor and the transmission speedo sensor. Also throwing a code that the front catalytic converters needs replaced. $2k bill from the shop. Have to fix it but concern is there may be a bigger issue causing all to go out at the same time. Anyone experience this?
Powers and grounds. Hopefully the shop has some good diag techs.

Sent from my SM-G970U1 using Tapatalk
 

·
Registered
Joined
·
1,496 Posts
Sounds nuts to happen all at once. I'd take it to a parts chain to have the codes read and the charging system checked for free.
 
1 - 3 of 3 Posts
Top