Focus Fanatics Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1,129 Posts
Discussion Starter #1
Had to be one of THE busiest intersections around too. But anyway driving along and all of a sudden there was a constant clicking going on in the dash. Just like the sound the fuse area makes when you turn on the rear window defrost. Next the entire dash freaks out and I start getting random warning lights on. ABS and TC go out and lose those. Then everything in the entire dash goes dead except the radio.

My friend driving in front of me said the HID's went out one at a time and kind of flickered off. Then as soon as I'm dead center in the intersection the motor bogs down extremely hard and shuts itself off right in the middle!

I've been told alternator. Hopefully it is...and it'll be a quick easy fix.

Any other opinions on what it could be?
 

·
Salmontheotherpinkmt
Joined
·
4,043 Posts
I say the alt would be a good starting point.I hope its nothing too serious!
 

·
because race car
Joined
·
1,948 Posts
thats what it sounds like, maybe even try a master fuse??? may not be the problem but it's alot easier and cheaper
 

·
Registered
Joined
·
240 Posts
check the connection to the altenator like the pigtail that connects to it pull on the 3 or 4 cables i belive cant remember lol ....and see if none of them got lose or just came out...same prob happend to me my car was flashing my lights like your and interior light on and off and no power till it die. so check that if thats the problem go to ford and get a new one and soder the new one on...

http://www.focusfanatics.com/forum/showthread.php?t=104396
 

·
Registered
Joined
·
1,129 Posts
Discussion Starter #5
check the connection to the altenator like the pigtail that connects to it pull on the 3 or 4 cables i belive cant remember lol ....and see if none of them got lose or just came out...same prob happend to me my car was flashing my lights like your and interior light on and off and no power till it die. so check that if thats the problem go to ford and get a new one and soder the new one on...

http://www.focusfanatics.com/forum/showthread.php?t=104396
Its inside the dealership waiting for Monday to roll around. I just had it towed straight there.

Thanks for the opinions. Its nice to have some ideas of what the problem could be so they don't screw me on pricing or parts.
 

·
Registered
Joined
·
240 Posts
no problem man, hope they do for a good price which i dought..tell them to replace what the car needs not what they want to put in your car cuz remember they make a hell of alot of money doin it there way.
 

·
Registered
Joined
·
64 Posts
mine's been doing this a lot lately, especially when it's cold/snowing outside. my alternator and pigtail are fine. when it happens i just disconnect my battery, my maf, and check my grounds. haven't found the solution, and i don't have the money to bring it to the dealer yet.
 

·
Registered
Joined
·
1,243 Posts
Sure sounds like the alt. to me. Don't let the dealer screw you on the price to replace it. Let them test it and if it is the alt. then replace it yourself much cheaper. Just my $.02
 

·
Registered
Joined
·
172 Posts
Sure sounds like the alt. to me. Don't let the dealer screw you on the price to replace it. Let them test it and if it is the alt. then replace it yourself much cheaper. Just my $.02
Completely agree, not only will they turn a 100 dollar unit into a 300 dollar one, but they'll charge ungodly labor. Alt' shouldn't be too hard to replace anyways. Take off the belt, unbolt old, re-bolt new, put on the belt, drive. [wiggle]
 

·
Registered
Joined
·
1,141 Posts
God I hope my alternator doesn't go out. Half of the PW blower kit would have to be taken off to get to the alternator. Good luck at the dealership Matt. Hopefully they will be reasonable.
 

·
Aurelius Pardus
Joined
·
26,535 Posts
oh wow that sucks....... come to think of it I saw a Prius doing the same thing yesterday. the headlights were going out one by one, then they were just kinda stuck there, lol.
 

·
Registered
Joined
·
2,803 Posts
The clicking in the dash would be one of the relays (which is what you're activating when you hit the rear window defroster). So yeah, if you get flickering power from the alternator for whatever reason (bad wire, connection or alternator) that noise is what you'll get. Now you just need to know what the problem is ; )
 

·
WhiteSTguy
Joined
·
5,390 Posts
Could be a bad battery. I knew mine was going out and then one day my car died once on the highway, good thing it was your typical bumper-to-bumper LA traffic as I was able to push the car faster then the traffic was flowing. Another good sign is the gauge cluster may act erratically or not come on when you first start your car. Replaced the battery and all problems went away.
 

·
Registered
Joined
·
1,129 Posts
Discussion Starter #16
Finally heard the cause of the problem a few minutes ago. Electrical short in some relay...causing the alt to fry. They are replacing both the relay and alt. I have no mechanical know how to do this stuff. Paying 471 bucks and change.

Thanks for all the ideas guys! You all know your stuff A LOT!
 

·
Registered
Joined
·
1,765 Posts
Finally heard the cause of the problem a few minutes ago. Electrical short in some relay...causing the alt to fry. They are replacing both the relay and alt. I have no mechanical know how to do this stuff. Paying 471 bucks and change.

Thanks for all the ideas guys! You all know your stuff A LOT!
seriously , for that kind of money you get mechanical know to do the alternator and whatever was burning there... you should buy a chiltons book and just read for fun... you would see that is really easy to work on the cars...
 

·
Registered
Joined
·
1,129 Posts
Discussion Starter #18
seriously , for that kind of money you get mechanical know to do the alternator and whatever was burning there... you should buy a chiltons book and just read for fun... you would see that is really easy to work on the cars...
Yea...probably should but don't take my little spare time to do that lol. I've been working a ton of hours and only thing I do besides work is school. Fun life of a college student!
 

·
I need BOOOOST!!!!!!
Joined
·
6,125 Posts
yep definately a power problem and like everybody else gonna say alternator. i had an alt go out on mine and it wouldnt run at all. instead of spending the $ to get it towed you should have had some1 bring you a fully charged battery to see if the car would crank or run. that way you could drive it to a mechanic instead of paying for the tow and at least then you would know what is causing the problem and like you said you dont have to worry about getting screwed for little mythical unicorns jumping around in your tail pipe poking holes causing them to have to replace the exhaust and charging an extra $900 for it.
 
1 - 19 of 19 Posts
Top