Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
240 Posts
Discussion Starter · #1 ·
This probably doesn't go here, but this is what happened.

I got in my focus to go to the store, started it up, and the O/D light was on, and it stayed on. I pushed the O/D button on the shifter and nothing happened. I turned my lights on, because I always do when I drive, and it went off. I started playing with the light switch and it will go on and off by turning it. Has anyone had this problem before?

Karl
 

·
GreyRice WOoT!
Joined
·
10,786 Posts
hmm that is odd, maybe altenator is bad or battery, dunno could be tons of stuff, wiring etc....
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #3 ·
I'm thinking it's a short of some kind, but I wanted to check here to see if it was something that had occurred before. I'll probably have to take it into the shop. :(
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #4 ·
Technically, wouldn't this problem be covered by the powertrain warranty? Because O/D is part of the Tranny which is part of the P/T...

Karl
 

·
my car breaks!
Joined
·
2,103 Posts
also, it might not be an overdrive problem in the first place, it might be your car throwing a tech code! have it checked.
 

·
Registered
Joined
·
240 Posts
Discussion Starter · #7 ·
Well I called the Ford dealership, and they said they can look at it Thursday at 1 pm. They said it may not be covered uner the powertrain warranty because it could be electrical. But oh well, I have a secondary warranty through the dealer I bought the car from, and they will reimburse me for any and all damages.
 
1 - 7 of 7 Posts
Top