Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Ok, so I have kind of a long story here so please bare with me. Almost four weeks ago I was driving my 2012 Ford Focus. I love this car it has never given me any trouble. As usual it ran perfectly for the 60 mile trip. I parked did an errand got back in and started it and I had an engine light on. Put it in reverse and it didn't go. I mean it didn't even try to shift. Put it in drive and away it went. although it seemed to have a lag in shifting. So I went to the nearest ford dealer a few blocks away. Showed the service guy left the car and walked to my next appt. Came back and they said they pulled it in and it worked perfectly until they went to take it back out and then it acted up again. Said It was the TCM, which I agreed. I was covered so they gave me a loaner and said it would be anywhere from two day to two weeks to get the part and would notify me when they got it. Two weeks pass and I call them on Monday for progress because I was flying out the next day for my honeymoon and didn't want to have their loaner car held up for the week if they were done. Was told the part was not in, I explained I was leaving and was told that was fine. two days later I get a call form the service manager telling me they needed the loaner back and the Tcm was put in the prior Thursday. (Frustrated) I explained I had talk to a service person on Monday ETC, and he said he would figure it out. I then said so I can pick it up when I get back and he said no the TCM fixed the shifting problem but now it chatter and shudders on the road test. ( It didn't do this before mind you) He said they thought it was the Transmission motor and it was 100$ an hour shop fee if they were to dig into it. And the loaner would not be offered cause it isn't under warranty. I told him there was no choice fix it and I would deal with it when I returned in a week. Fast forward a week I haven't heard back from them. I get back to work and call them and the manger is out. But from what the service guy could tell is the motor was not bad but now they see a leak in the seal and I need a new seal and clutch. 1200$ I asked why They hadn't gotten to it in the previous week and called me and was told the guy looking at it was out sick for two days. I am not happy at this point. They are letting me keep the loaner but I guess my question is does this sound legit? The care ran beautifully until the TCM quit. They know that was bad.... but now I have this other issue that just happed to coincide???? My friends think it sounds off, as do I. Any thoughts would be appreciated Thank you
 

·
C2H5OH
Joined
·
11,868 Posts

·
Old Phart
Joined
·
44,596 Posts
Moved to the MkIII Problems section since it's not a DIY repair question.

More responses & information in this section.
 

·
Registered
Joined
·
250 Posts
Clutch replacement should be covered under the 14M01 warranty extension.

Had the same thing happen with my SEL and they replaced the rear main bearing seal and clutch under 14M01.
 
1 - 6 of 6 Posts
Top